]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/default.nix
Nicecoop installation
[perso/Immae/Config/Nix.git] / modules / private / default.nix
1 let
2 set = {
3 # adatped from nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
4 httpdInte = import ../websites/httpd-service-builder.nix { httpdName = "Inte"; withUsers = false; };
5 httpdProd = import ../websites/httpd-service-builder.nix { httpdName = "Prod"; withUsers = false; };
6 httpdTools = import ../websites/httpd-service-builder.nix { httpdName = "Tools"; withUsers = true; };
7
8 databases = ./databases;
9 mariadb = ./databases/mariadb.nix;
10 openldap = ./databases/openldap;
11 postgresql = ./databases/postgresql.nix;
12 redis = ./databases/redis.nix;
13 postgresqlReplication = ./databases/postgresql_replication.nix;
14 mariadbReplication = ./databases/mariadb_replication.nix;
15 redisReplication = ./databases/redis_replication.nix;
16 openldapReplication = ./databases/openldap_replication.nix;
17
18 websites = ./websites;
19 gemini = ./gemini;
20
21
22 # Personal websites
23 bakeerCloud = ./websites/bakeer/cloud.nix;
24
25 capitainesLandingPages = ./websites/capitaines/landing_pages.nix;
26
27 chloeInte = ./websites/chloe/integration.nix;
28 chloeProd = ./websites/chloe/production.nix;
29
30 cipcaSympa = ./websites/cip-ca/sympa.nix;
31
32 connexionswingInte = ./websites/connexionswing/integration.nix;
33 connexionswingProd = ./websites/connexionswing/production.nix;
34
35 deniseDenisejeromeProd = ./websites/denise/denisejerome.nix;
36 deniseEvariste = ./websites/denise/evariste.nix;
37 deniseOMS = ./websites/denise/oms.nix;
38 deniseBingo = ./websites/denise/bingo.nix;
39 deniseAventuriers = ./websites/denise/aventuriers.nix;
40 deniseProduction = ./websites/denise/production.nix;
41
42 emiliaMoodle = ./websites/emilia/moodle.nix;
43 emiliaAtelierFringant = ./websites/emilia/atelierfringant.nix;
44
45 florianApp = ./websites/florian/app.nix;
46 florianInte = ./websites/florian/integration.nix;
47 florianProd = ./websites/florian/production.nix;
48
49 immaeProd = ./websites/immae/production.nix;
50 immaeRelease = ./websites/immae/release.nix;
51 immaeTemp = ./websites/immae/temp.nix;
52
53 isabelleAtenInte = ./websites/isabelle/aten_integration.nix;
54 isabelleAtenProd = ./websites/isabelle/aten_production.nix;
55 isabelleIridologie = ./websites/isabelle/iridologie.nix;
56
57 jeromeNaturaloutil = ./websites/jerome/naturaloutil.nix;
58
59 leilaProd = ./websites/leila/production.nix;
60
61 ludivineInte = ./websites/ludivine/integration.nix;
62 ludivineProd = ./websites/ludivine/production.nix;
63
64 nassimeProd = ./websites/nassime/production.nix;
65
66 nathVillon = ./websites/nath/villon.nix;
67
68 nicecoopGestionCompte = ./websites/nicecoop/gestion-compte.nix;
69 nicecoopGestionCompteIntegration = ./websites/nicecoop/gestion-compte_integration.nix;
70 nicecoopOdoo = ./websites/nicecoop/odoo.nix;
71
72 papaMaisonBbc = ./websites/papa/maison_bbc.nix;
73 papaSurveillance = ./websites/papa/surveillance.nix;
74
75 patrickFodellaEcolyeu = ./websites/patrick_fodella/ecolyeu.nix;
76 patrickFodellaAltermondia = ./websites/patrick_fodella/altermondia.nix;
77
78 piedsjalouxInte = ./websites/piedsjaloux/integration.nix;
79 piedsjalouxProd = ./websites/piedsjaloux/production.nix;
80
81 ressourcerieBanonProd = ./websites/ressourcerie_banon/production.nix;
82 ressourcerieBanonCloud = ./websites/ressourcerie_banon/cloud.nix;
83 ressourcerieBanonCryptpad = ./websites/ressourcerie_banon/cryptpad.nix;
84
85 richieProd = ./websites/richie/production.nix;
86
87 sydenPeertube = ./websites/syden/peertube.nix;
88
89 teliotortayProd = ./websites/telio_tortay/production.nix;
90
91 # Tools
92 assetsTools = ./websites/tools/assets;
93 cloudTool = ./websites/tools/cloud;
94 cloudFarmTool = ./websites/tools/cloud/farm.nix;
95 cryptpadTool = ./websites/tools/cryptpad;
96 cryptpadFarmTool = ./websites/tools/cryptpad/farm.nix;
97 commentoTool = ./websites/tools/commento;
98 davTool = ./websites/tools/dav;
99 vpnTool = ./websites/tools/vpn;
100 dbTool = ./websites/tools/db;
101 diasporaTool = ./websites/tools/diaspora;
102 etherTool = ./websites/tools/ether;
103 gitTool = ./websites/tools/git;
104 imTool = ./websites/tools/im;
105 mastodonTool = ./websites/tools/mastodon;
106 mgoblinTool = ./websites/tools/mgoblin;
107 peertubeTool = ./websites/tools/peertube;
108 performanceTool = ./websites/tools/performance;
109 toolsTool = ./websites/tools/tools;
110 mailTool = ./websites/tools/mail;
111 statsTool = ./websites/tools/stats;
112
113 # Games
114 codenamesGame = ./websites/tools/games/codenames;
115 terraformingMarsGame = ./websites/tools/games/terraforming-mars;
116
117 mail = ./mail;
118
119 buildbot = ./buildbot;
120 certificates = ./certificates.nix;
121 gitolite = ./gitolite;
122 irc = ./irc.nix;
123 pub = ./pub;
124 tasks = ./tasks;
125 dns = ./dns.nix;
126 ftp = ./ftp.nix;
127 mpd = ./mpd.nix;
128 ejabberd = ./ejabberd;
129 ssh = ./ssh;
130 monitoring = ./monitoring;
131 status = ./monitoring/status.nix;
132 status_engine = ./monitoring/status_engine.nix;
133 vpn = ./vpn;
134
135 environment = ./environment.nix;
136 system = ./system.nix;
137 loginctl-linger = ./loginctl-linger.nix;
138 };
139 in
140 builtins.listToAttrs (map (attr: { name = "priv${attr}"; value = set.${attr}; }) (builtins.attrNames set))