]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/default.nix
Add coturn server
[perso/Immae/Config/Nix.git] / modules / private / default.nix
1 let
2 set = {
3 # adatped from nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
4 httpdInte = import ../websites/httpd-service-builder.nix { httpdName = "Inte"; withUsers = false; };
5 httpdProd = import ../websites/httpd-service-builder.nix { httpdName = "Prod"; withUsers = false; };
6 httpdTools = import ../websites/httpd-service-builder.nix { httpdName = "Tools"; withUsers = true; };
7
8 coturn = ./coturn.nix;
9 databases = ./databases;
10 mariadb = ./databases/mariadb.nix;
11 openldap = ./databases/openldap;
12 postgresql = ./databases/postgresql.nix;
13 redis = ./databases/redis.nix;
14 postgresqlReplication = ./databases/postgresql_replication.nix;
15 mariadbReplication = ./databases/mariadb_replication.nix;
16 redisReplication = ./databases/redis_replication.nix;
17 openldapReplication = ./databases/openldap_replication.nix;
18
19 websites = ./websites;
20 gemini = ./gemini;
21
22
23 # Personal websites
24 bakeerCloud = ./websites/bakeer/cloud.nix;
25
26 capitainesLandingPages = ./websites/capitaines/landing_pages.nix;
27
28 chloeProd = ./websites/chloe/production.nix;
29 chloeNew = ./websites/chloe/new.nix;
30
31 christopheCarpentierWebsite = ./websites/christophe_carpentier/website.nix;
32 christopheCarpentierAgorakit = ./websites/christophe_carpentier/agorakit.nix;
33 christopheCarpentierAgoraProject = ./websites/christophe_carpentier/agora-project.nix;
34
35 cipcaSympa = ./websites/cip-ca/sympa.nix;
36
37 connexionswingInte = ./websites/connexionswing/integration.nix;
38 connexionswingProd = ./websites/connexionswing/production.nix;
39
40 deniseDenisejeromeProd = ./websites/denise/denisejerome.nix;
41 deniseEvariste = ./websites/denise/evariste.nix;
42 deniseOMS = ./websites/denise/oms.nix;
43 deniseBingo = ./websites/denise/bingo.nix;
44 deniseAventuriers = ./websites/denise/aventuriers.nix;
45 deniseProduction = ./websites/denise/production.nix;
46
47 emiliaMoodle = ./websites/emilia/moodle.nix;
48 emiliaAtelierFringant = ./websites/emilia/atelierfringant.nix;
49
50 florianApp = ./websites/florian/app.nix;
51 florianInte = ./websites/florian/integration.nix;
52 florianProd = ./websites/florian/production.nix;
53
54 immaeProd = ./websites/immae/production.nix;
55 immaeRelease = ./websites/immae/release.nix;
56 immaeTemp = ./websites/immae/temp.nix;
57
58 isabelleAtenInte = ./websites/isabelle/aten_integration.nix;
59 isabelleAtenProd = ./websites/isabelle/aten_production.nix;
60 isabelleIridologie = ./websites/isabelle/iridologie.nix;
61
62 jeromeNaturaloutil = ./websites/jerome/naturaloutil.nix;
63
64 leilaProd = ./websites/leila/production.nix;
65
66 librezoCloud = ./websites/librezo/nextcloud.nix;
67 librezoDolibarr = ./websites/librezo/dolibarr.nix;
68 librezoDolibarrDev = ./websites/librezo/dolibarr_integration.nix;
69 librezoWebsite = ./websites/librezo/website.nix;
70
71 ludivineInte = ./websites/ludivine/integration.nix;
72 ludivineProd = ./websites/ludivine/production.nix;
73
74 nassimeProd = ./websites/nassime/production.nix;
75
76 nathVillon = ./websites/nath/villon.nix;
77
78 nicecoopGestionCompte = ./websites/nicecoop/gestion-compte.nix;
79 nicecoopGestionCompteIntegration = ./websites/nicecoop/gestion-compte_integration.nix;
80 nicecoopOdoo = ./websites/nicecoop/odoo.nix;
81 nicecoopCopanier = ./websites/nicecoop/copanier.nix;
82
83 papaMaisonBbc = ./websites/papa/maison_bbc.nix;
84 papaSurveillance = ./websites/papa/surveillance.nix;
85
86 patrickFodellaEcolyeu = ./websites/patrick_fodella/ecolyeu.nix;
87 patrickFodellaAltermondia = ./websites/patrick_fodella/altermondia.nix;
88
89 piedsjalouxInte = ./websites/piedsjaloux/integration.nix;
90 piedsjalouxProd = ./websites/piedsjaloux/production.nix;
91
92 ressourcerieBanonProd = ./websites/ressourcerie_banon/production.nix;
93 ressourcerieBanonCloud = ./websites/ressourcerie_banon/cloud.nix;
94 ressourcerieBanonCryptpad = ./websites/ressourcerie_banon/cryptpad.nix;
95
96 richieProd = ./websites/richie/production.nix;
97
98 sydenPeertube = ./websites/syden/peertube.nix;
99
100 teliotortayProd = ./websites/telio_tortay/production.nix;
101
102 # Tools
103 assetsTools = ./websites/tools/assets;
104 cloudTool = ./websites/tools/cloud;
105 cloudFarmTool = ./websites/tools/cloud/farm.nix;
106 cryptpadTool = ./websites/tools/cryptpad;
107 cryptpadFarmTool = ./websites/tools/cryptpad/farm.nix;
108 commentoTool = ./websites/tools/commento;
109 davTool = ./websites/tools/dav;
110 vpnTool = ./websites/tools/vpn;
111 dbTool = ./websites/tools/db;
112 diasporaTool = ./websites/tools/diaspora;
113 etherTool = ./websites/tools/ether;
114 gitTool = ./websites/tools/git;
115 imTool = ./websites/tools/im;
116 mastodonTool = ./websites/tools/mastodon;
117 mgoblinTool = ./websites/tools/mgoblin;
118 peertubeTool = ./websites/tools/peertube;
119 performanceTool = ./websites/tools/performance;
120 toolsTool = ./websites/tools/tools;
121 mailTool = ./websites/tools/mail;
122 statsTool = ./websites/tools/stats;
123 visioTool = ./websites/tools/visio;
124
125 # Games
126 codenamesGame = ./websites/tools/games/codenames;
127 terraformingMarsGame = ./websites/tools/games/terraforming-mars;
128
129 mail = ./mail;
130
131 buildbot = ./buildbot;
132 certificates = ./certificates.nix;
133 gitolite = ./gitolite;
134 irc = ./irc.nix;
135 pub = ./pub;
136 tasks = ./tasks;
137 dns = ./dns.nix;
138 ftp = ./ftp.nix;
139 mpd = ./mpd.nix;
140 ejabberd = ./ejabberd;
141 ssh = ./ssh;
142 monitoring = ./monitoring;
143 status = ./monitoring/status.nix;
144 status_engine = ./monitoring/status_engine.nix;
145 vpn = ./vpn;
146
147 environment = ./environment.nix;
148 system = ./system.nix;
149 loginctl-linger = ./loginctl-linger.nix;
150 };
151 in
152 builtins.listToAttrs (map (attr: { name = "priv${attr}"; value = set.${attr}; }) (builtins.attrNames set))