1 { stdenv, mylibs, fetchFromGitHub, fetchurl, fetchgit, callPackage, nodePackages, nodejs-10_x }:
3 nodeEnv = callPackage mylibs.nodeEnv { nodejs = nodejs-10_x; };
4 # built using node2nix -8 -l package-lock.json
5 # and changing "./." to "src"
6 packageEnv = import ./node-packages.nix {
7 src = stdenv.mkDerivation ({
8 pname = "iota-cli-app";
9 version = "d7e2e08-master";
10 src = fetchFromGitHub {
13 rev = "d7e2e0856ae6bd34890fefb4245c07cd467a5032";
14 sha256 = "1n9kczsxdgjv8282nj2grlijvxipiskx0ndn169vz6v1l1hrwc8b";
15 fetchSubmodules = true;
17 phases = "installPhase";
22 sed -i -e "s@host: 'http://localhost',@host: 'https://nodes.thetangle.org',@" index.js
23 sed -i -e "s@port: 14265@port: 443@" index.js
26 inherit fetchurl fetchgit nodeEnv;