]>
Commit | Line | Data |
---|---|---|
1 | { lib, config, ... }: | |
2 | let | |
3 | cfg = config.myServices.websites.cip-ca.sympa; | |
4 | in | |
5 | { | |
6 | options.myServices.websites.cip-ca.sympa.enable = lib.mkEnableOption "enable cip-ca’s sympa website"; | |
7 | config = lib.mkIf cfg.enable { | |
8 | services.websites.env.tools.vhostConfs.cipca_sympa = { | |
9 | certName = "cip-ca"; | |
10 | certMainHost = "mail.cip-ca.fr"; | |
11 | hosts = [ "mail.cip-ca.fr" ]; | |
12 | root = null; | |
13 | extraConfig = [ | |
14 | '' | |
15 | Alias /static-sympa/ /var/lib/sympa/static_content/ | |
16 | <Directory /var/lib/sympa/static_content/> | |
17 | Require all granted | |
18 | AllowOverride none | |
19 | </Directory> | |
20 | <Location /sympa> | |
21 | SetHandler "proxy:unix:/run/sympa/wwsympa.socket|fcgi://" | |
22 | Require all granted | |
23 | </Location> | |
24 | '' | |
25 | ]; | |
26 | }; | |
27 | }; | |
28 | } |