]>
Commit | Line | Data |
---|---|---|
1 | { | |
2 | description = "Immae Specific uids"; | |
3 | ||
4 | outputs = { self }: { | |
5 | lib = { | |
6 | # Check that there is no clash with nixos/modules/misc/ids.nix | |
7 | uids = { | |
8 | cryptpad = 386; | |
9 | postfixscripts = 387; | |
10 | acme = 388; | |
11 | backup = 389; | |
12 | vhost = 390; | |
13 | openarc = 391; | |
14 | opendmarc = 392; | |
15 | peertube = 394; | |
16 | redis = 395; | |
17 | nullmailer = 396; | |
18 | mediagoblin = 397; | |
19 | diaspora = 398; | |
20 | mastodon = 399; | |
21 | }; | |
22 | gids = { | |
23 | nagios = 11; # commented in the ids file | |
24 | cryptpad = 386; | |
25 | acme = 388; | |
26 | backup = 389; | |
27 | vhost = 390; | |
28 | openarc = 391; | |
29 | opendmarc = 392; | |
30 | peertube = 394; | |
31 | redis = 395; | |
32 | nullmailer = 396; | |
33 | mediagoblin = 397; | |
34 | diaspora = 398; | |
35 | mastodon = 399; | |
36 | }; | |
37 | }; | |
38 | nixosModule = { ... }: { | |
39 | config = { | |
40 | ids.uids = self.lib.uids; | |
41 | ids.gids = self.lib.gids; | |
42 | }; | |
43 | }; | |
44 | }; | |
45 | } |