]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame_incremental - flakes/mypackages/pkgs/webapps/default.nix
Fix warning for loki
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / webapps / default.nix
... / ...
CommitLineData
1{ callPackage, mylibs, composerEnv, sources }:
2rec {
3 adminer = callPackage ./adminer {};
4 apache-theme = import ./apache-theme;
5 awl = callPackage ./awl {};
6 davical = callPackage ./davical {};
7 dokuwiki = callPackage ./dokuwiki {};
8 infcloud = callPackage ./infcloud {};
9 mantisbt_2 = callPackage ./mantisbt_2 {};
10 nextcloud_25 = callPackage ./nextcloud { nextcloudVersion = 25; };
11 nextcloud_26 = callPackage ./nextcloud { nextcloudVersion = 26; };
12 nextcloud_27 = callPackage ./nextcloud { nextcloudVersion = 27; };
13 nextcloud_27_2 = callPackage ./nextcloud { nextcloudVersion = "27_2"; };
14 # required postgresql and php upgrade!
15 #nextcloud_28 = callPackage ./nextcloud { nextcloudVersion = 28; };
16 #nextcloud_29 = callPackage ./nextcloud { nextcloudVersion = 29; };
17 nextcloud_25-all = nextcloud_25.withApps (a: builtins.attrValues nextcloud_25.allSupportedApps);
18 nextcloud_26-all = nextcloud_26.withApps (a: builtins.attrValues nextcloud_26.allSupportedApps);
19 nextcloud_27-all = nextcloud_27.withApps (a: builtins.attrValues nextcloud_27.allSupportedApps);
20 nextcloud_27_2-all = nextcloud_27_2.withApps (a: builtins.attrValues nextcloud_27_2.allSupportedApps);
21 # required postgresql and php upgrade!
22 #nextcloud_28-all = nextcloud_28.withApps (a: builtins.attrValues nextcloud_28.allSupportedApps);
23 #nextcloud_29-all = nextcloud_29.withApps (a: builtins.attrValues nextcloud_29.allSupportedApps);
24 phpbb = callPackage ./phpbb {};
25 phpldapadmin = callPackage ./phpldapadmin {};
26 rompr = callPackage ./rompr {};
27 roundcubemail = callPackage ./roundcubemail {};
28 spip = callPackage ./spip {};
29 ttrss = callPackage ./ttrss { inherit sources; };
30 wallabag = callPackage ./wallabag { inherit composerEnv; };
31 yourls = callPackage ./yourls {};
32}