]>
Commit | Line | Data |
---|---|---|
c54f73c3 | 1 | { lib, python3Packages, fetchgit }: |
98de2045 IB |
2 | with python3Packages; |
3 | buildPythonPackage rec { | |
4 | pname = "Telethon-sync"; | |
5 | version = "1.1.1"; | |
6 | ||
c54f73c3 | 7 | src = fetchgit { |
9d1d44e4 | 8 | url = "https://github.com/LonamiWebs/Telethon"; |
c54f73c3 | 9 | branchName = "sync-stale"; |
9d1d44e4 | 10 | rev = "6a785a01aa56cfd21c8c5beb9d722c68d664ba5e"; |
c54f73c3 | 11 | sha256 = "0g7gnln5kbh1gy6sfb3jg6knmi33n6sgzy2rni2x6af84lza0lgc"; |
98de2045 IB |
12 | }; |
13 | ||
14 | propagatedBuildInputs = [ | |
15 | rsa pyaes async_generator | |
16 | ]; | |
17 | doCheck = false; | |
18 | ||
19 | meta = with lib; { | |
20 | homepage = https://github.com/LonamiWebs/Telethon; | |
21 | description = "Full-featured Telegram client library for Python 3"; | |
22 | license = licenses.mit; | |
23 | }; | |
24 | } |