]>
Commit | Line | Data |
---|---|---|
8c4f6e37 IB |
1 | { buildPerlPackage, fetchurl, perlPackages, lib }: |
2 | buildPerlPackage rec { | |
3 | name = "mtop-${version}"; | |
4 | version = "0.6.6"; | |
5 | src = fetchurl { | |
6 | url = "http://downloads.sourceforge.net/project/mtop/mtop/v${version}/mtop-${version}.tar.gz"; | |
7 | sha256 = "0x0x5300b1j9i0xxk8rsrki0pspyzj2vylhzv8qg3l6j26aw0zrf"; | |
8 | }; | |
9 | outputs = ["out"]; | |
10 | buildInputs = with perlPackages; [ DBI DBDmysql Curses ]; | |
11 | ||
12 | postInstall = '' | |
13 | cd "$out" | |
14 | preConfigure || true | |
15 | ''; | |
16 | ||
17 | meta = with lib; { | |
18 | description = "MySQL top (monitor and examine slow queries)"; | |
19 | homepage = http://mtop.sourceforge.net/; | |
20 | license = licenses.gpl3; | |
21 | maintainers = with maintainers; [ { name = "Marc Prewitt"; email = "mprewitt@chelsea.net"; } ]; | |
22 | platforms = platforms.unix; | |
23 | }; | |
24 | } |