]>
Commit | Line | Data |
---|---|---|
dff8b593 IB |
1 | { stdenv, mylibs, libetpan, openssl, autoconf, groff, slang, yacc }: |
2 | stdenv.mkDerivation (mylibs.fetchedGithub ./flrn.json // { | |
98de2045 IB |
3 | buildInputs = [ libetpan openssl autoconf groff slang yacc ]; |
4 | preConfigure = '' | |
5 | sed -i -e "s/test -e configure/false/" configure.in | |
6 | autoconf | |
7 | sed -i -e '/define CHECK_MAIL/d' src/flrn_config.h | |
8 | sed -i -e '/DEFAULT_DIR_FILE/s@".flrn"@".config/flrn"@' src/flrn_config.h | |
9 | sed -i -e '/DEFAULT_CONFIG_FILE/s@".flrnrc"@"flrnrc"@' src/flrn_config.h | |
10 | sed -i -e '/DEFAULT_FLNEWS_FILE/s@".flnewsrc"@"flnewsrc"@' src/flrn_config.h | |
11 | sed -i -e '/flrn_char chaine/s@18@20@' src/flrn_command.c | |
12 | ''; | |
13 | }) |