]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - pkgs/default.nix
Add ntfy notification pusher
[perso/Immae/Config/Nix.git] / pkgs / default.nix
CommitLineData
fdf6f74d
IB
1{ pkgs }:
2with pkgs;
1bd8b03e 3let
dbcba2ea 4 mylibs = import ../lib { inherit pkgs; };
b924f671 5in
fd2d83bd 6rec {
ccda44f3 7 sources = import ../nix/sources.nix;
8c90ed19 8 myEnvironments = callPackage ../environments {};
f780f42a 9 bash-libs = callPackage ./bash-libs {};
ccda44f3
IB
10 boinctui = callPackage ./boinctui {};
11 cnagios = callPackage ./cnagios { inherit mylibs; };
6338573a 12 commento = callPackage ./commento {};
ccda44f3 13 flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
61777b7e
IB
14 fluentd = callPackage ./fluentd {};
15 fluent-bit = callPackage ./fluent-bit {};
ccda44f3
IB
16 genius = callPackage ./genius {};
17 mtop = callPackage ./mtop {};
18 muttprint = callPackage ./muttprint {};
19 mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
20 nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
21 nagnu = callPackage ./nagnu { inherit mylibs; };
033bd2b4 22 nb = callPackage ./nb {};
ccda44f3
IB
23 note = callPackage ./note {};
24 notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
e34b3079 25 notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python38Packages; };
ccda44f3 26 notmuch-vim = callPackage ./notmuch/notmuch-vim {};
f780f42a 27 pgpid = callPackage ./pgpid {};
ccda44f3
IB
28 predixy = callPackage ./predixy { inherit mylibs; };
29 rrsync_sudo = callPackage ./rrsync_sudo {};
a3ef18ac 30 signaldctl = callPackage ./signaldctl {};
ccda44f3
IB
31 telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
32 telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
33 terminal-velocity = callPackage ./terminal-velocity {};
34 tiv = callPackage ./tiv {};
ef118cb3 35 twins = callPackage ./twins {};
a565d58b 36 umami = callPackage ./umami {};
ccda44f3 37 unicodeDoc = callPackage ./unicode {};
6e2dc958 38
ccda44f3
IB
39 cardano = callPackage ./crypto/cardano { inherit mylibs; };
40 cardano-cli = callPackage ./crypto/cardano-cli {};
41 iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
42 sia = callPackage ./crypto/sia {};
6e2dc958 43
fcbdf67a 44 proftpd = callPackage ./proftpd {};
ccda44f3 45 pure-ftpd = callPackage ./pure-ftpd {};
521a721d 46
1017ce8e 47 composerEnv = callPackage ./composer-env {};
d3452fc5 48 webapps = callPackage ./webapps { inherit mylibs composerEnv; };
1bd8b03e 49
3bc32d9e
IB
50 monitoring-plugins = callPackage ./monitoring-plugins {};
51 naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
52 naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
a97118c4
IB
53 gearmand = callPackage ./gearmand {};
54 status_engine = {
55 module = callPackage ./status_engine/module.nix { inherit mylibs; };
56 worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
57 interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
58 };
3bc32d9e 59
b798cf6d 60 python3PackagesPlus = callPackage ./python-packages {
e34b3079 61 python = python38;
b798cf6d
IB
62 inherit mylibs;
63 };
a929614f
IB
64 dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
65 inherit mylibs;
66 };
6e2dc958 67}