]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - pkgs/default.nix
Install noctambules
[perso/Immae/Config/Nix.git] / pkgs / default.nix
CommitLineData
fdf6f74d
IB
1{ pkgs }:
2with pkgs;
1bd8b03e 3let
dbcba2ea 4 mylibs = import ../lib { inherit pkgs; };
b924f671 5in
fd2d83bd 6rec {
ccda44f3 7 sources = import ../nix/sources.nix;
8c90ed19 8 myEnvironments = callPackage ../environments {};
ccda44f3
IB
9 boinctui = callPackage ./boinctui {};
10 cnagios = callPackage ./cnagios { inherit mylibs; };
6338573a 11 commento = callPackage ./commento {};
ccda44f3 12 flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
61777b7e
IB
13 fluentd = callPackage ./fluentd {};
14 fluent-bit = callPackage ./fluent-bit {};
ccda44f3
IB
15 genius = callPackage ./genius {};
16 mtop = callPackage ./mtop {};
17 muttprint = callPackage ./muttprint {};
18 mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
19 nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
20 nagnu = callPackage ./nagnu { inherit mylibs; };
033bd2b4 21 nb = callPackage ./nb {};
ccda44f3
IB
22 note = callPackage ./note {};
23 notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
24 notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
25 notmuch-vim = callPackage ./notmuch/notmuch-vim {};
ccda44f3
IB
26 pgloader = callPackage ./pgloader {};
27 predixy = callPackage ./predixy { inherit mylibs; };
28 rrsync_sudo = callPackage ./rrsync_sudo {};
a3ef18ac 29 signaldctl = callPackage ./signaldctl {};
ccda44f3
IB
30 telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
31 telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
32 terminal-velocity = callPackage ./terminal-velocity {};
33 tiv = callPackage ./tiv {};
ef118cb3 34 twins = callPackage ./twins {};
a565d58b 35 umami = callPackage ./umami {};
ccda44f3 36 unicodeDoc = callPackage ./unicode {};
6e2dc958 37
ccda44f3
IB
38 cardano = callPackage ./crypto/cardano { inherit mylibs; };
39 cardano-cli = callPackage ./crypto/cardano-cli {};
40 iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
41 sia = callPackage ./crypto/sia {};
6e2dc958 42
fcbdf67a 43 proftpd = callPackage ./proftpd {};
ccda44f3 44 pure-ftpd = callPackage ./pure-ftpd {};
521a721d 45
1017ce8e 46 composerEnv = callPackage ./composer-env {};
d3452fc5 47 webapps = callPackage ./webapps { inherit mylibs composerEnv; };
1bd8b03e 48
3bc32d9e
IB
49 monitoring-plugins = callPackage ./monitoring-plugins {};
50 naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
51 naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
a97118c4
IB
52 gearmand = callPackage ./gearmand {};
53 status_engine = {
54 module = callPackage ./status_engine/module.nix { inherit mylibs; };
55 worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
56 interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
57 };
3bc32d9e 58
b798cf6d
IB
59 python3PackagesPlus = callPackage ./python-packages {
60 python = python3;
61 inherit mylibs;
62 };
a929614f
IB
63 dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
64 inherit mylibs;
65 };
6e2dc958 66}