]>
Commit | Line | Data |
---|---|---|
e570c4f5 | 1 | { gitweb, writeText, gitolite, git, gitoliteDir, highlight }: |
5c101474 | 2 | rec { |
950ca5ee | 3 | varDir = gitoliteDir; |
5c101474 IB |
4 | webRoot = gitweb; |
5 | config = writeText "gitweb.conf" '' | |
6 | $git_temp = "/tmp"; | |
cf80b4f2 | 7 | |
5c101474 IB |
8 | # The directories where your projects are. Must not end with a |
9 | # slash. | |
10 | $projectroot = "${varDir}/repositories"; | |
cf80b4f2 | 11 | |
5c101474 IB |
12 | $projects_list = "${varDir}/projects.list"; |
13 | $strict_export = "true"; | |
cf80b4f2 | 14 | |
5c101474 IB |
15 | # Base URLs for links displayed in the web interface. |
16 | our @git_base_url_list = qw(ssh://gitolite@git.immae.eu https://git.immae.eu); | |
cf80b4f2 | 17 | |
5c101474 IB |
18 | $feature{'blame'}{'default'} = [1]; |
19 | $feature{'avatar'}{'default'} = ['gravatar']; | |
20 | $feature{'highlight'}{'default'} = [1]; | |
cf80b4f2 | 21 | |
5c101474 IB |
22 | @stylesheets = ("gitweb-theme/gitweb.css"); |
23 | $logo = "gitweb-theme/git-logo.png"; | |
24 | $favicon = "gitweb-theme/git-favicon.png"; | |
25 | $javascript = "gitweb-theme/gitweb.js"; | |
26 | $logo_url = "https://git.immae.eu/"; | |
27 | $projects_list_group_categories = "true"; | |
28 | $projects_list_description_width = 60; | |
29 | $project_list_default_category = "__Others__"; | |
e570c4f5 | 30 | $highlight_bin = "${highlight}/bin/highlight"; |
5c101474 | 31 | ''; |
a95ab089 | 32 | apache = rec { |
5c101474 IB |
33 | user = "wwwrun"; |
34 | group = "wwwrun"; | |
35 | modules = [ "cgid" ]; | |
a95ab089 IB |
36 | webappName = "tools_gitweb"; |
37 | root = "/run/current-system/webapps/${webappName}"; | |
5c101474 IB |
38 | vhostConf = '' |
39 | SetEnv GIT_PROJECT_ROOT ${varDir}/repositories/ | |
40 | ScriptAliasMatch \ | |
41 | "(?x)^/(.*/(HEAD | \ | |
42 | info/refs | \ | |
43 | objects/(info/[^/]+ | \ | |
44 | [0-9a-f]{2}/[0-9a-f]{38} | \ | |
45 | pack/pack-[0-9a-f]{40}\.(pack|idx)) | \ | |
46 | git-(upload|receive)-pack))$" \ | |
47 | ${git}/libexec/git-core/git-http-backend/$1 | |
cf80b4f2 | 48 | |
5c101474 IB |
49 | <Directory "${git}/libexec/git-core"> |
50 | Require all granted | |
51 | </Directory> | |
a95ab089 | 52 | <Directory "${root}"> |
5c101474 IB |
53 | DirectoryIndex gitweb.cgi |
54 | Require all granted | |
55 | AllowOverride None | |
56 | Options ExecCGI FollowSymLinks | |
57 | <Files gitweb.cgi> | |
58 | SetHandler cgi-script | |
59 | SetEnv GITWEB_CONFIG "${config}" | |
60 | </Files> | |
61 | </Directory> | |
62 | ''; | |
cf80b4f2 | 63 | }; |
5c101474 | 64 | } |