]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/ressourcerie_banon/cloud.nix
Ateliers du changement
[perso/Immae/Config/Nix.git] / modules / private / websites / ressourcerie_banon / cloud.nix
CommitLineData
54d97019
IB
1{ lib, pkgs, config, ... }:
2let
3 cfg = config.myServices.websites.ressourcerie_banon.cloud;
54d97019
IB
4in {
5 options.myServices.websites.ressourcerie_banon.cloud.enable = lib.mkEnableOption "enable Ressourcerie Banon’s cloud";
6
7 config = lib.mkIf cfg.enable {
792ccef2
IB
8 myServices.tools.cloud.farm.instances.ressourcerie_banon = {
9 nextcloud = pkgs.webapps.nextcloud_22;
10 apps = a: [ a.calendar ];
11 };
54d97019
IB
12 services.websites.env.production.modules = [ "proxy_fcgi" ];
13 services.websites.env.production.vhostConfs.ressourcerie_banon_cloud = {
14 certName = "ressourcerie_banon";
15 addToCerts = true;
16 hosts = ["cloud.le-garage-autonome.org"];
792ccef2 17 root = config.myServices.tools.cloud.farm.rootDirs.ressourcerie_banon;
54d97019
IB
18 extraConfig = [ config.myServices.tools.cloud.farm.vhosts.ressourcerie_banon ];
19 };
20 };
21}
22