]>
Commit | Line | Data |
---|---|---|
ab8f306d | 1 | { lib, pkgs, config, ... }: |
f8026b6e IB |
2 | let |
3 | adminer = pkgs.callPackage ../commons/adminer.nix {}; | |
4 | cfg = config.myServices.websites.florian.production; | |
5 | varDir = "/var/lib/ftp/florian"; | |
ab8f306d | 6 | env = config.myEnv.websites.florian; |
f8026b6e IB |
7 | in { |
8 | options.myServices.websites.florian.production.enable = lib.mkEnableOption "enable Florian's website production"; | |
9 | ||
10 | config = lib.mkIf cfg.enable { | |
11 | security.acme.certs."ftp".extraDomains."tellesflorian.com" = null; | |
12 | ||
29f8cb85 IB |
13 | services.websites.env.production.modules = adminer.apache.modules; |
14 | services.websites.env.production.vhostConfs.florian = { | |
f8026b6e IB |
15 | certName = "florian"; |
16 | certMainHost = "tellesflorian.com"; | |
17 | hosts = [ "tellesflorian.com" "www.tellesflorian.com" ]; | |
18 | root = "${varDir}/tellesflorian.com"; | |
19 | extraConfig = [ | |
20 | adminer.apache.vhostConf | |
21 | '' | |
22 | ServerAdmin ${env.server_admin} | |
23 | ||
24 | <Directory ${varDir}/tellesflorian.com> | |
25 | DirectoryIndex index.php index.htm index.html | |
26 | Options Indexes FollowSymLinks MultiViews Includes | |
27 | AllowOverride None | |
28 | Require all granted | |
29 | </Directory> | |
30 | '' | |
31 | ]; | |
32 | }; | |
33 | }; | |
34 | } |