]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/default.nix
Add dolibarr for immae
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
CommitLineData
ab8f306d 1{ lib, pkgs, config, ... }:
4288c2f2 2let
750fe5a4
IB
3 www_root = ./_www;
4 theme_root = pkgs.webapps.apache-theme.theme;
4288c2f2 5 apacheConfig = {
9271611c
IB
6 cache = {
7 # This setting permits to ignore time-based cache for files in the
8 # nix store:
9 # If a client requires an If-Modified-Since from timestamp 1, then
10 # this header is removed, and if the response contains a
11 # too old Last-Modified tag, then it is removed too
12 extraConfig = ''
13 <If "%{HTTP:If-Modified-Since} =~ /01 Jan 1970 00:00:01/" >
14 RequestHeader unset If-Modified-Since
15 </If>
16 Header unset Last-Modified "expr=%{LAST_MODIFIED} < 19991231235959"
17 '';
18 };
4288c2f2
IB
19 gzip = {
20 modules = [ "deflate" "filter" ];
21 extraConfig = ''
22 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
23 '';
24 };
25 macros = {
26 modules = [ "macro" ];
27 };
28 stats = {
29 extraConfig = ''
30 <Macro Stats %{domain}>
31 Alias /webstats ${config.services.webstats.dataDir}/%{domain}
32 <Directory ${config.services.webstats.dataDir}/%{domain}>
33 DirectoryIndex index.html
34 AllowOverride None
35 Require all granted
36 </Directory>
37 <Location /webstats>
38 Use LDAPConnect
39 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
40 </Location>
41 </Macro>
42 '';
43 };
44 ldap = {
45 modules = [ "ldap" "authnz_ldap" ];
46 extraConfig = ''
47 <IfModule ldap_module>
48 LDAPSharedCacheSize 500000
49 LDAPCacheEntries 1024
50 LDAPCacheTTL 600
51 LDAPOpCacheEntries 1024
52 LDAPOpCacheTTL 600
53 </IfModule>
54
da30ae4f 55 Include ${config.secrets.fullPaths."apache-ldap"}
4288c2f2
IB
56 '';
57 };
58 global = {
d3452fc5
IB
59 extraConfig = ''
60 ErrorDocument 500 /maintenance_immae.html
61 ErrorDocument 501 /maintenance_immae.html
62 ErrorDocument 502 /maintenance_immae.html
63 ErrorDocument 503 /maintenance_immae.html
64 ErrorDocument 504 /maintenance_immae.html
65 Alias /maintenance_immae.html ${www_root}/maintenance_immae.html
66 ProxyPass /maintenance_immae.html !
67
68 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${www_root}/googleb6d69446ff4ca3e5.html
69 <Directory ${www_root}>
70 AllowOverride None
71 Require all granted
72 </Directory>
73 '';
4288c2f2
IB
74 };
75 apaxy = {
76 extraConfig = (pkgs.webapps.apache-theme.override { inherit theme_root; }).apacheConfig;
77 };
78 http2 = {
79 modules = [ "http2" ];
80 extraConfig = ''
81 Protocols h2 http/1.1
82 '';
83 };
84 customLog = {
85 extraConfig = ''
494d0718 86 LogFormat "%{Host}i:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
4288c2f2
IB
87 '';
88 };
89 };
90 makeModules = lib.lists.flatten (lib.attrsets.mapAttrsToList (n: v: v.modules or []) apacheConfig);
91 makeExtraConfig = (builtins.filter (x: x != null) (lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) apacheConfig));
36861e95
IB
92 moomin = let
93 lines = lib.splitString "\n" (lib.fileContents ./moomin.txt);
94 pad = width: str: let
95 padWidth = width - lib.stringLength str;
96 padding = lib.concatStrings (lib.genList (lib.const "0") padWidth);
97 in lib.optionalString (padWidth > 0) padding + str;
98 in
99 lib.imap0 (i: e: ''Header always set "X-Moomin-${pad 2 (builtins.toString i)}" "${e}"'') lines;
4288c2f2 100in
f8026b6e 101{
d3452fc5 102 options.myServices.websites.enable = lib.mkEnableOption "enable websites";
4288c2f2 103
8415083e 104 config = lib.mkIf config.myServices.websites.enable {
4288c2f2
IB
105 users.users.wwwrun.extraGroups = [ "keys" ];
106 networking.firewall.allowedTCPPorts = [ 80 443 ];
107
4c4652aa 108 secrets.keys."apache-ldap" = {
4288c2f2
IB
109 user = "wwwrun";
110 group = "wwwrun";
111 permissions = "0400";
112 text = ''
113 <Macro LDAPConnect>
114 <IfModule authnz_ldap_module>
115 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
116 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
ab8f306d 117 AuthLDAPBindPassword "${config.myEnv.httpd.ldap.password}"
4288c2f2
IB
118 AuthType Basic
119 AuthName "Authentification requise (Acces LDAP)"
120 AuthBasicProvider ldap
121 </IfModule>
122 </Macro>
123 '';
4c4652aa 124 };
4288c2f2
IB
125
126 system.activationScripts = {
127 httpd = ''
3ffa15ba 128 install -d -m 0755 /var/lib/acme/acme-challenges
4288c2f2
IB
129 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
130 '';
131 };
132
133 services.phpfpm = {
4288c2f2
IB
134 phpOptions = ''
135 session.save_path = "/var/lib/php/sessions"
136 post_max_size = 20M
137 ; 15 days (seconds)
138 session.gc_maxlifetime = 1296000
139 ; 30 days (minutes)
140 session.cache_expire = 43200
141 '';
5400b9b6
IB
142 settings = {
143 log_level = "notice";
144 };
4288c2f2
IB
145 };
146
da30ae4f
IB
147 services.filesWatcher.httpdProd.paths = [ config.secrets.fullPaths."apache-ldap" ];
148 services.filesWatcher.httpdInte.paths = [ config.secrets.fullPaths."apache-ldap" ];
149 services.filesWatcher.httpdTools.paths = [ config.secrets.fullPaths."apache-ldap" ];
17f6eae9 150
29f8cb85 151 services.websites.env.production = {
4288c2f2
IB
152 enable = true;
153 adminAddr = "httpd@immae.eu";
154 httpdName = "Prod";
155 ips =
ab8f306d 156 let ips = config.myEnv.servers.eldiron.ips.production;
05becbbb 157 in (ips.ip4 or []) ++ (ips.ip6 or []);
4288c2f2
IB
158 modules = makeModules;
159 extraConfig = makeExtraConfig;
160 fallbackVhost = {
161 certName = "eldiron";
162 hosts = ["eldiron.immae.eu" ];
163 root = www_root;
164 extraConfig = [ "DirectoryIndex index.htm" ];
165 };
166 };
167
29f8cb85 168 services.websites.env.integration = {
4288c2f2
IB
169 enable = true;
170 adminAddr = "httpd@immae.eu";
171 httpdName = "Inte";
172 ips =
ab8f306d 173 let ips = config.myEnv.servers.eldiron.ips.integration;
05becbbb 174 in (ips.ip4 or []) ++ (ips.ip6 or []);
4288c2f2 175 modules = makeModules;
36861e95 176 extraConfig = makeExtraConfig ++ moomin;
4288c2f2 177 fallbackVhost = {
2ff9258e 178 certName = "integration";
4288c2f2
IB
179 hosts = ["eldiron.immae.eu" ];
180 root = www_root;
181 extraConfig = [ "DirectoryIndex index.htm" ];
182 };
183 };
184
29f8cb85 185 services.websites.env.tools = {
4288c2f2
IB
186 enable = true;
187 adminAddr = "httpd@immae.eu";
188 httpdName = "Tools";
189 ips =
ab8f306d 190 let ips = config.myEnv.servers.eldiron.ips.main;
05becbbb 191 in (ips.ip4 or []) ++ (ips.ip6 or []);
4288c2f2
IB
192 modules = makeModules;
193 extraConfig = makeExtraConfig ++
194 [ ''
195 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
196 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
197 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
198 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
199 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
200 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
201 ''
202 ];
203 nosslVhost = {
204 enable = true;
205 host = "nossl.immae.eu";
206 };
207 fallbackVhost = {
208 certName = "eldiron";
209 hosts = ["eldiron.immae.eu" ];
210 root = www_root;
211 extraConfig = [ "DirectoryIndex index.htm" ];
212 };
213 };
214
f69e0c01
IB
215 myServices.tools.kanboard.farm.instances.tonnelle = {};
216 myServices.tools.kanboard.farm.instances.gebull = {};
4288c2f2 217 myServices.websites = {
a58a80b2
IB
218 attilax.dolibarr.enable = true;
219
abd7458c 220 bakeer.cloud.enable = true;
d3452fc5 221 capitaines.landing_pages.enable = true;
4288c2f2 222
d3452fc5 223 chloe = {
2ff9258e 224 new.enable = true;
d3452fc5
IB
225 production.enable = true;
226 };
4288c2f2 227
5a412244
IB
228 christophe_carpentier = {
229 website.enable = true;
230 agorakit.enable = true;
231 agora-project.enable = true;
232 };
233
6c7d42fc
IB
234 cip-ca = {
235 sympa.enable = true;
236 };
237
d3452fc5
IB
238 connexionswing = {
239 integration.enable = true;
240 production.enable = true;
241 };
f8026b6e 242
d3452fc5
IB
243 denise = {
244 evariste.enable = true;
245 denisejerome.enable = true;
a295d69f 246 oms.enable = true;
2e573da3 247 bingo.enable = true;
f989f3ed 248 aventuriers.enable = true;
a295d69f 249 production.enable = true;
d3452fc5 250 };
f8026b6e 251
c0c7c8b5
IB
252 emilia = {
253 moodle.enable = false;
254 atelierfringant.enable = true;
255 };
f8026b6e 256
d3452fc5
IB
257 florian = {
258 app.enable = true;
259 integration.enable = true;
260 production.enable = true;
261 };
f8026b6e 262
d3452fc5
IB
263 immae = {
264 production.enable = true;
265 release.enable = true;
266 temp.enable = true;
568bfa04 267 dolibarr.enable = true;
d3452fc5 268 };
f8026b6e 269
d3452fc5
IB
270 isabelle = {
271 aten_integration.enable = true;
272 aten_production.enable = true;
273 iridologie.enable = true;
274 };
f8026b6e 275
d3452fc5 276 jerome.naturaloutil.enable = true;
f8026b6e 277
4288c2f2 278 leila.production.enable = true;
f8026b6e 279
5c9a5ec7
IB
280 librezo = {
281 cloud.enable = true;
282 dolibarr.enable = true;
283 dolibarrDev.enable = true;
284 website.enable = true;
285 };
286
d3452fc5
IB
287 ludivine = {
288 integration.enable = true;
289 production.enable = true;
290 };
f8026b6e 291
4288c2f2 292 nassime.production.enable = true;
f8026b6e 293
965b61c2
IB
294 nicecoop = {
295 gestion-compte.enable = true;
296 gestion-compte-integration.enable = true;
297 odoo.enable = true;
27da4e10 298 copanier.enable = true;
965b61c2 299 };
76799447
IB
300
301 noctambules = {
302 cloud.enable = true;
303 };
304
d3452fc5
IB
305 papa = {
306 surveillance.enable = true;
307 maison_bbc.enable = true;
308 };
f8026b6e 309
305922df
IB
310 patrick_fodella = {
311 ecolyeu.enable = true;
312 altermondia.enable = true;
313 };
982dc1fa 314
d3452fc5
IB
315 piedsjaloux = {
316 integration.enable = true;
317 production.enable = true;
318 };
f8026b6e 319
54d97019
IB
320 ressourcerie_banon.production.enable = true;
321 ressourcerie_banon.cryptpad.enable = true;
322 ressourcerie_banon.cloud.enable = true;
323
d3452fc5 324 richie.production.enable = true;
f8026b6e 325
8a05c7fb
IB
326 syden.peertube.enable = true;
327
d3452fc5
IB
328 telio_tortay.production.enable = true;
329
4c42e0be 330 tools.assets.enable = true;
4288c2f2 331 tools.cloud.enable = true;
6338573a 332 tools.commento.enable = true;
8c91e92c 333 tools.cryptpad.enable = true;
4288c2f2
IB
334 tools.dav.enable = true;
335 tools.db.enable = true;
336 tools.diaspora.enable = true;
337 tools.etherpad-lite.enable = true;
338 tools.git.enable = true;
339 tools.mastodon.enable = true;
340 tools.mediagoblin.enable = true;
341 tools.peertube.enable = true;
a97118c4 342 tools.performance.enable = true;
4288c2f2 343 tools.tools.enable = true;
afcc5de0 344 tools.email.enable = true;
a565d58b 345 tools.stats.enable = false;
bdaca01e 346 tools.visio.enable = true;
de6002a1
IB
347
348 games.codenames.enable = true;
f036e975 349 games.terraforming-mars.enable = true;
4288c2f2
IB
350 };
351 };
f8026b6e 352}