]>
Commit | Line | Data |
---|---|---|
6ee77836 IB |
1 | { lib, hostFQDN, emailCheck, ... }: |
2 | let | |
3 | defaultPassiveInfo = { | |
4 | filter = lib.attrsets.filterAttrs | |
5 | (k: v: builtins.elem k ["service_description"] || builtins.substring 0 1 k == "_"); | |
6 | use = "external-passive-service"; | |
7 | freshness_threshold = "450"; | |
8 | retry_interval = "1"; | |
9 | servicegroups = "webstatus-resources"; | |
10 | host_name = hostFQDN; | |
11 | }; | |
12 | in | |
13 | { | |
14 | service = [ | |
f7a3019f IB |
15 | { |
16 | passiveInfo = defaultPassiveInfo // { servicegroups = "webstatus-resources"; }; | |
17 | service_description = "No RAID device is degraded"; | |
18 | use = "local-service"; | |
19 | check_command = ["check_megaraid"]; | |
20 | } | |
6ee77836 IB |
21 | ]; |
22 | } |