]>
Commit | Line | Data |
---|---|---|
e820134d IB |
1 | { config, ... }: |
2 | { | |
3 | contact = { | |
4 | immae = config.myEnv.monitoring.contacts.immae // { | |
5 | use = "generic-contact"; | |
6 | contactgroups = "admins"; | |
7 | host_notification_commands = "notify-host-by-email,notify-by-slack!$USER206$!$USER207$"; | |
8 | service_notification_commands = "notify-service-by-email,notify-by-slack!$USER206$!$USER207$"; | |
9 | }; | |
10 | }; | |
11 | command = { | |
12 | check_passive = "$USER1$/check_dummy 3 \"Service result are stale\""; | |
13 | }; | |
14 | templates = { | |
15 | service = { | |
16 | external-passive-service = { | |
17 | active_checks_enabled = "0"; | |
18 | check_freshness = "1"; | |
19 | check_period = "24x7"; | |
20 | contact_groups = "admins"; | |
21 | event_handler_enabled = "1"; | |
22 | flap_detection_enabled = "1"; | |
23 | is_volatile = "0"; | |
24 | max_check_attempts = "3"; | |
25 | notification_interval = "60"; | |
26 | notification_options = "w,u,c,r,f,s"; | |
27 | notification_period = "24x7"; | |
28 | notifications_enabled = "1"; | |
29 | passive_checks_enabled = "1"; | |
30 | process_perf_data = "1"; | |
31 | retain_nonstatus_information = "1"; | |
32 | retain_status_information = "1"; | |
33 | retry_interval = "2"; | |
34 | check_command = "check_passive"; | |
35 | }; | |
36 | }; | |
37 | }; | |
38 | } |