]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/default.nix
Postfix common aliases
[perso/Immae/Config/Nix.git] / modules / default.nix
CommitLineData
776aa360 1flakes:
e8864bbf 2let
776aa360
IB
3 public = flakes.subflakes.public;
4 flakeLib = flakes.subflakes.public.lib.lib;
e8864bbf 5in
996a68c2 6{
776aa360
IB
7 myids = public.myuids.nixosModule;
8 secrets = flakeLib.withNarKey public.secrets "nixosModule";
9 #filesWatcher = flakeLib.withNarKey public.files-watcher "nixosModule";
996a68c2 10
9eae2b47 11 webstats = ./webapps/webstats;
776aa360
IB
12 diaspora = public.diaspora.nixosModule;
13 etherpad-lite = public.etherpad-lite.nixosModule;
14 mastodon = public.mastodon.nixosModule;
15 mediagoblin = public.mediagoblin.nixosModule;
16 peertube = public.peertube.nixosModule;
17 fiche = flakeLib.withNarKey public.fiche "nixosModule";
daf64e3f 18
776aa360
IB
19 #paste = flakeLib.withNarKey public.paste "nixosModule";
20
21 #opendmarc = flakeLib.withNarKey public.opendmarc "nixosModule";
22 #openarc = flakeLib.withNarKey public.openarc "nixosModule";
411af8e3 23
d2e703c5 24 duplyBackup = ./duply_backup;
776aa360 25 rsyncBackup = flakeLib.withNarKey public.rsync_backup "nixosModule";
3bc32d9e
IB
26 naemon = ./naemon;
27
5dda316b 28 zrepl = ./zrepl.nix;
daf64e3f 29 websites = ./websites;
581c499c 30} // (if builtins.pathExists ./private then import ./private else {})