]>
Commit | Line | Data |
---|---|---|
1be9e64b IB |
1 | { |
2 | description = "Immae Specific uids"; | |
3 | ||
4 | outputs = { self }: { | |
5 | lib = { | |
6 | # Check that there is no clash with nixos/modules/misc/ids.nix | |
7 | uids = { | |
8 | acme = 388; | |
9 | backup = 389; | |
10 | vhost = 390; | |
11 | openarc = 391; | |
12 | opendmarc = 392; | |
13 | peertube = 394; | |
14 | redis = 395; | |
15 | nullmailer = 396; | |
16 | mediagoblin = 397; | |
17 | diaspora = 398; | |
18 | mastodon = 399; | |
19 | }; | |
20 | gids = { | |
21 | nagios = 11; # commented in the ids file | |
22 | acme = 388; | |
23 | backup = 389; | |
24 | vhost = 390; | |
25 | openarc = 391; | |
26 | opendmarc = 392; | |
27 | peertube = 394; | |
28 | redis = 395; | |
29 | nullmailer = 396; | |
30 | mediagoblin = 397; | |
31 | diaspora = 398; | |
32 | mastodon = 399; | |
33 | }; | |
34 | }; | |
35 | nixosModule = { ... }: { | |
36 | config = { | |
37 | ids.uids = self.lib.uids; | |
38 | ids.gids = self.lib.gids; | |
39 | }; | |
40 | }; | |
41 | }; | |
42 | } |