]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - flakes/grocy/flake.nix
migrate secondary DNS to Raito
[perso/Immae/Config/Nix.git] / flakes / grocy / flake.nix
CommitLineData
bc0f9fcf
IB
1{
2 description = "ERP beyond your fridge - grocy is a web-based self-hosted groceries & household management solution for your home";
3 inputs.flake-utils.url = "github:numtide/flake-utils";
4 inputs.nixpkgs = {
5 url = "github:NixOS/nixpkgs/840c782d507d60aaa49aa9e3f6d0b0e780912742";
6 flake = false;
7 };
8 inputs.grocy = {
9 url = "github:grocy/grocy/d7738aa1ec330c81f11e4976681df0299d4ed35a";
10 flake = false;
11 };
12 outputs = { self, nixpkgs, grocy, flake-utils }: flake-utils.lib.eachSystem ["x86_64-linux"] (system:
13 let
14 pkgs = import nixpkgs { inherit system; overlays = []; };
15 composerEnv = pkgs.callPackage ../../pkgs/composer-env {};
16 version = (builtins.fromJSON (builtins.readFile ./flake.lock)).nodes.grocy.original.ref;
17 inherit (pkgs) callPackage;
18 in rec {
19 packages.grocy = callPackage ./. { inherit composerEnv; src = grocy // { inherit version; }; };
20 defaultPackage = packages.grocy;
21 legacyPackages.grocy = packages.grocy;
22 checks = {
23 build = defaultPackage;
24 };
25 }
26 ) // rec {
27 overlays = {
28 grocy = final: prev: {
29 grocy = self.defaultPackage."${final.system}";
30 };
31 };
32 overlay = overlays.grocy;
33 };
34}