aboutsummaryrefslogtreecommitdiff
path: root/music_sampler.spec
diff options
context:
space:
mode:
Diffstat (limited to 'music_sampler.spec')
-rw-r--r--music_sampler.spec3
1 files changed, 2 insertions, 1 deletions
diff --git a/music_sampler.spec b/music_sampler.spec
index 791cd68..5549b76 100644
--- a/music_sampler.spec
+++ b/music_sampler.spec
@@ -1,5 +1,6 @@
1# -*- mode: python -*- 1# -*- mode: python -*-
2import os 2import os
3import setuptools_scm
3from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal,\ 4from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal,\
4 hookspath, runtime_hooks 5 hookspath, runtime_hooks
5 6
@@ -22,7 +23,7 @@ excluded_and_hidden_modules['hiddenimports'] += [
22 'packaging.specifiers', 23 'packaging.specifiers',
23 'packaging.requirements' ] 24 'packaging.requirements' ]
24 25
25commit_message = os.popen('git log -1 --format="%h %ci"').read() 26commit_message = setuptools_scm.get_version()
26pyinstaller_file = open(".pyinstaller_commit", "w") 27pyinstaller_file = open(".pyinstaller_commit", "w")
27pyinstaller_file.write(commit_message) 28pyinstaller_file.write(commit_message)
28pyinstaller_file.close() 29pyinstaller_file.close()