aboutsummaryrefslogtreecommitdiff
path: root/music_sampler.spec
diff options
context:
space:
mode:
Diffstat (limited to 'music_sampler.spec')
-rw-r--r--music_sampler.spec9
1 files changed, 8 insertions, 1 deletions
diff --git a/music_sampler.spec b/music_sampler.spec
index ef949f2..7a885fd 100644
--- a/music_sampler.spec
+++ b/music_sampler.spec
@@ -1,14 +1,21 @@
1# -*- mode: python -*- 1# -*- mode: python -*-
2import os
2from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal, hookspath, runtime_hooks 3from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal, hookspath, runtime_hooks
3 4
4excluded_and_hidden_modules = get_deps_minimal(video=None, camera=None, audio=None, clipboard=None, spelling=None) 5excluded_and_hidden_modules = get_deps_minimal(video=None, camera=None, audio=None, clipboard=None, spelling=None)
5excluded_and_hidden_modules['hiddenimports'] += [ 'six', 'packaging', 'packaging.version', 'packaging.specifiers', 'packaging.requirements'] 6excluded_and_hidden_modules['hiddenimports'] += [ 'six', 'packaging', 'packaging.version', 'packaging.specifiers', 'packaging.requirements']
6 7
8commit_message = os.popen('git log -1 --format="%h %ci"').read()
9pyinstaller_file = open(".pyinstaller_commit", "w")
10pyinstaller_file.write(commit_message)
11pyinstaller_file.close()
12
7a = Analysis(['music_sampler.py'], 13a = Analysis(['music_sampler.py'],
8 binaries=None, 14 binaries=None,
9 datas=[ 15 datas=[
10 ('fonts/*', 'fonts'), 16 ('fonts/*', 'fonts'),
11 ('music_sampler.kv', '.') 17 ('music_sampler.kv', '.'),
18 ('.pyinstaller_commit', '.')
12 ], 19 ],
13 hookspath=hookspath(), 20 hookspath=hookspath(),
14 runtime_hooks=runtime_hooks(), 21 runtime_hooks=runtime_hooks(),