aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@fretlink.com>2021-08-16 22:27:12 +0200
committerIsmaël Bouya <ismael.bouya@fretlink.com>2021-08-17 02:14:46 +0200
commit7b4791cfb73136db35160989c08660db55c3c34e (patch)
treecf82e793ded811abc23e793734a3628a7f22cbcd /pyproject.toml
parentb45837641542cf18e2410dcbaa7ecba1bdc3905d (diff)
downloadMusicSampler-7b4791cfb73136db35160989c08660db55c3c34e.tar.gz
MusicSampler-7b4791cfb73136db35160989c08660db55c3c34e.tar.zst
MusicSampler-7b4791cfb73136db35160989c08660db55c3c34e.zip
Upgrade to latest versions1.6.0
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..5fd4d3a
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,41 @@
1[tool.poetry]
2name = "music_sampler"
3version = "1.6.0"
4description = "A music player which associates each key on the keyboard to a set of actions to run"
5authors = ["Ismaël Bouya <ismael.bouya@normalesup.org>", "Denise Maurice <denise.maurice@normalesup.org"]
6license = "MIT"
7keywords = ["music", "sampler", "keyboard"]
8readme = "README"
9homepage = "https://git.immae.eu/cgit/perso/Immae/Projets/Python/MusicSampler.git/about/"
10repository = "https://git.immae.eu/perso/Immae/Projets/Python/MusicSampler.git"
11include = [
12 "music_sampler/locales/fr/LC_MESSAGES/*.mo",
13 "run.py"
14]
15classifiers = [
16 'Development Status :: 5 - Production/Stable',
17 'Intended Audience :: End Users/Desktop',
18 'Topic :: Multimedia :: Sound/Audio :: Players'
19]
20
21[tool.poetry.dependencies]
22python = "^3.9"
23pydub = "^0.25.1"
24sounddevice = "^0.4.2"
25transitions = "^0.8.8"
26PyYAML = "^5.4.1"
27Kivy = "^2.0.0"
28
29[tool.poetry.dev-dependencies]
30Markdown = "^3.3.4"
31Pygments = "^2.10.0"
32shiv = "^0.5.2"
33pyinstaller = "^4.5.1"
34setuptools-scm = "^6.0.1"
35
36[tool.poetry.scripts]
37music_sampler = "music_sampler.app:main"
38
39[build-system]
40requires = ["poetry-core>=1.0.0"]
41build-backend = "poetry.core.masonry.api"