summaryrefslogtreecommitdiff
path: root/pkgs/terminal-velocity/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/terminal-velocity/default.nix')
-rw-r--r--pkgs/terminal-velocity/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/terminal-velocity/default.nix b/pkgs/terminal-velocity/default.nix
new file mode 100644
index 00000000..9e79deea
--- /dev/null
+++ b/pkgs/terminal-velocity/default.nix
@@ -0,0 +1,33 @@
1{ python36Packages }:
2with python36Packages;
3buildPythonApplication rec {
4 pname = "terminal-velocity-git";
5 version = "0.2.0";
6 src = fetchPypi {
7 inherit pname version;
8 sha256 = "13yrkcmvh5h5fwnai61sbmqkrjyisz08n62pq0ada2lyyqf7g6b9";
9 };
10
11 patches = [
12 ./sort_found_notes.patch
13 ./python3_support.patch
14 # FIXME: update this patch when version changes
15 ./fix_build.patch
16 ];
17
18 propagatedBuildInputs = [
19 chardet
20 urwid
21 (sh.overridePythonAttrs { doCheck = false; })
22 pyyaml
23 ];
24 buildInputs = [
25 m2r
26 (restructuredtext_lint.overridePythonAttrs { doCheck = false; })
27 pygments
28 ];
29
30 postInstall = ''
31 rm $out/bin/terminal_velocity
32 '';
33}