summaryrefslogtreecommitdiff
path: root/pkgs/private/webapps/apache-default/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/private/webapps/apache-default/default.nix')
-rw-r--r--pkgs/private/webapps/apache-default/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/private/webapps/apache-default/default.nix b/pkgs/private/webapps/apache-default/default.nix
new file mode 100644
index 00000000..92f558eb
--- /dev/null
+++ b/pkgs/private/webapps/apache-default/default.nix
@@ -0,0 +1,21 @@
1{ www_root ? null }:
2rec {
3 www = ./www;
4 apacheConfig = let
5 www_root' = if isNull www_root then www else www_root;
6 in ''
7 ErrorDocument 500 /maintenance_immae.html
8 ErrorDocument 501 /maintenance_immae.html
9 ErrorDocument 502 /maintenance_immae.html
10 ErrorDocument 503 /maintenance_immae.html
11 ErrorDocument 504 /maintenance_immae.html
12 Alias /maintenance_immae.html ${www_root'}/maintenance_immae.html
13 ProxyPass /maintenance_immae.html !
14
15 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${www_root'}/googleb6d69446ff4ca3e5.html
16 <Directory ${www_root'}>
17 AllowOverride None
18 Require all granted
19 </Directory>
20 '';
21}