diff options
Diffstat (limited to 'pkgs/opendmarc')
-rw-r--r-- | pkgs/opendmarc/default.nix | 26 | ||||
-rw-r--r-- | pkgs/opendmarc/libspf2.nix | 35 |
2 files changed, 61 insertions, 0 deletions
diff --git a/pkgs/opendmarc/default.nix b/pkgs/opendmarc/default.nix new file mode 100644 index 00000000..1c502482 --- /dev/null +++ b/pkgs/opendmarc/default.nix | |||
@@ -0,0 +1,26 @@ | |||
1 | { stdenv, fetchurl, pkgconfig, libbsd, openssl, libmilter , perl, makeWrapper, libspf2 }: | ||
2 | |||
3 | stdenv.mkDerivation rec { | ||
4 | name = "opendmarc-${version}"; | ||
5 | version = "1.3.2"; | ||
6 | |||
7 | src = fetchurl { | ||
8 | url = "mirror://sourceforge/opendmarc/files/${name}.tar.gz"; | ||
9 | sha256 = "1yrggj8yq0915y2i34gfz2xpl1w2lgb1vggp67rwspgzm40lng11"; | ||
10 | }; | ||
11 | |||
12 | configureFlags= [ | ||
13 | "--with-spf" | ||
14 | "--with-spf2-include=${libspf2}/include/spf2" | ||
15 | "--with-spf2-lib=${libspf2}/lib/" | ||
16 | "--with-milter=${libmilter}" | ||
17 | ]; | ||
18 | |||
19 | buildInputs = [ libspf2 libbsd openssl libmilter perl ]; | ||
20 | |||
21 | meta = with stdenv.lib; { | ||
22 | description = "Free open source software implementation of the DMARC specification"; | ||
23 | homepage = http://www.trusteddomain.org/opendmarc/; | ||
24 | platforms = platforms.unix; | ||
25 | }; | ||
26 | } | ||
diff --git a/pkgs/opendmarc/libspf2.nix b/pkgs/opendmarc/libspf2.nix new file mode 100644 index 00000000..ca02d59f --- /dev/null +++ b/pkgs/opendmarc/libspf2.nix | |||
@@ -0,0 +1,35 @@ | |||
1 | { stdenv, file, fetchurl, fetchpatch, libnsl }: | ||
2 | |||
3 | stdenv.mkDerivation rec { | ||
4 | name = "libspf2-${version}"; | ||
5 | version = "1.2.10"; | ||
6 | |||
7 | patches = [ | ||
8 | (fetchpatch { | ||
9 | name = "fix-variadic-macros.patch"; | ||
10 | url = "https://git.archlinux.org/svntogit/community.git/plain/trunk/fix-variadic-macros.patch?h=packages/libspf2"; | ||
11 | sha256 = "00dqpcgjr9jy2qprgqv2qiyvq8y3wlz4yns9xzabf2064jzqh2ic"; | ||
12 | }) | ||
13 | ]; | ||
14 | preConfigure = '' | ||
15 | sed -i -e "s@/usr/bin/file@${file}/bin/file@" ./configure | ||
16 | ''; | ||
17 | configureFlags = [ | ||
18 | "--enable-static" | ||
19 | ]; | ||
20 | postInstall = '' | ||
21 | rm $out/bin/*_static | ||
22 | ''; | ||
23 | src = fetchurl { | ||
24 | url = "https://www.libspf2.org/spf/${name}.tar.gz"; | ||
25 | sha256 = "1j91p0qiipzf89qxq4m1wqhdf01hpn1h5xj4djbs51z23bl3s7nr"; | ||
26 | }; | ||
27 | |||
28 | buildInputs = [ libnsl ]; | ||
29 | |||
30 | meta = with stdenv.lib; { | ||
31 | description = "Sender Policy Framework record checking library"; | ||
32 | homepage = https://www.libspf2.org/; | ||
33 | platforms = platforms.unix; | ||
34 | }; | ||
35 | } | ||