summaryrefslogtreecommitdiff
path: root/modules/private/websites/piedsjaloux/integration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/piedsjaloux/integration.nix')
-rw-r--r--modules/private/websites/piedsjaloux/integration.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/modules/private/websites/piedsjaloux/integration.nix b/modules/private/websites/piedsjaloux/integration.nix
new file mode 100644
index 00000000..5f574e1a
--- /dev/null
+++ b/modules/private/websites/piedsjaloux/integration.nix
@@ -0,0 +1,32 @@
1{ lib, pkgs, config, myconfig, ... }:
2let
3 piedsjaloux = pkgs.callPackage ./builder.nix {
4 inherit (pkgs.webapps) piedsjaloux;
5 config = myconfig.env.websites.piedsjaloux.integration;
6 apacheUser = config.services.httpd.Inte.user;
7 apacheGroup = config.services.httpd.Inte.group;
8 };
9
10 cfg = config.myServices.websites.piedsjaloux.integration;
11in {
12 options.myServices.websites.piedsjaloux.integration.enable = lib.mkEnableOption "enable PiedsJaloux's website in integration";
13
14 config = lib.mkIf cfg.enable {
15 secrets.keys = piedsjaloux.keys;
16 systemd.services.phpfpm-piedsjaloux_dev.after = lib.mkAfter piedsjaloux.phpFpm.serviceDeps;
17 systemd.services.phpfpm-piedsjaloux_dev.wants = piedsjaloux.phpFpm.serviceDeps;
18 systemd.services.phpfpm-piedsjaloux_dev.preStart = lib.mkAfter piedsjaloux.phpFpm.preStart;
19 services.phpfpm.poolConfigs.piedsjaloux_dev = piedsjaloux.phpFpm.pool;
20 system.activationScripts.piedsjaloux_dev = piedsjaloux.activationScript;
21 myServices.websites.webappDirs."${piedsjaloux.apache.webappName}" = piedsjaloux.app.webRoot;
22 services.websites.integration.modules = piedsjaloux.apache.modules;
23 services.websites.integration.vhostConfs.piedsjaloux = {
24 certName = "eldiron";
25 addToCerts = true;
26 hosts = [ "piedsjaloux.immae.eu" ];
27 root = piedsjaloux.apache.root;
28 extraConfig = [ piedsjaloux.apache.vhostConf ];
29 };
30 };
31}
32