diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2018-12-13 21:25:24 +0100 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-05-24 01:40:13 +0200 |
commit | 24fd1fe6c62b7a9fc347794fde043285da272f5c (patch) | |
tree | 65557bf1d241ca389b619dbd24d18d51932ee030 /pkgs/webapps/roundcubemail | |
download | NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.gz NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.zst NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.zip |
Initial commit published for NUR
Diffstat (limited to 'pkgs/webapps/roundcubemail')
9 files changed, 117 insertions, 0 deletions
diff --git a/pkgs/webapps/roundcubemail/default.nix b/pkgs/webapps/roundcubemail/default.nix new file mode 100644 index 00000000..ba85f372 --- /dev/null +++ b/pkgs/webapps/roundcubemail/default.nix | |||
@@ -0,0 +1,61 @@ | |||
1 | { varDir ? "/var/lib/roundcubemail" | ||
2 | , roundcube_config ? "/etc/roundcube/config.php" | ||
3 | , stdenv, fetchurl }: | ||
4 | let | ||
5 | defaultInstall = '' | ||
6 | mkdir -p $out | ||
7 | cp -R . $out/ | ||
8 | cd $out | ||
9 | if [ -d skins -a -d skins/larry -a ! -d skins/elastic ]; then | ||
10 | ln -s larry skins/elastic | ||
11 | fi | ||
12 | ''; | ||
13 | buildPlugin = { appName, version, url, sha256, installPhase ? defaultInstall }: | ||
14 | stdenv.mkDerivation rec { | ||
15 | name = "roundcube-${appName}-${version}"; | ||
16 | inherit version; | ||
17 | phases = "unpackPhase installPhase"; | ||
18 | inherit installPhase; | ||
19 | src = fetchurl { inherit url sha256; }; | ||
20 | passthru.pluginName = appName; | ||
21 | }; | ||
22 | withPlugins = plugins: skins: package.overrideAttrs(old: { | ||
23 | name = "${old.name}${if builtins.length skins > 0 then "-with-skins" else ""}${if builtins.length plugins > 0 then "-with-plugins" else ""}"; | ||
24 | installPhase = old.installPhase + | ||
25 | builtins.concatStringsSep "\n" ( | ||
26 | map (value: "ln -s ${value} $out/plugins/${value.pluginName}") plugins | ||
27 | ) + | ||
28 | builtins.concatStringsSep "\n" ( | ||
29 | map (value: "ln -s ${value} $out/skins/${value.skinName}") skins | ||
30 | ); | ||
31 | passthru = old.passthru // { | ||
32 | inherit plugins skins; | ||
33 | withPlugins = morePlugins: moreSkins: old.withPlugins (morePlugins ++ plugins) (morePlugins ++ skins); | ||
34 | }; | ||
35 | }); | ||
36 | package = stdenv.mkDerivation rec { | ||
37 | version = "1.4-rc1"; | ||
38 | name = "roundcubemail-${version}"; | ||
39 | src= fetchurl { | ||
40 | url = "https://github.com/roundcube/roundcubemail/releases/download/${version}/${name}-complete.tar.gz"; | ||
41 | sha256 = "0p18wffwi2prh6vxhx1bc69qd1vwybggm8gvg3shahfdknxci9i4"; | ||
42 | }; | ||
43 | buildPhase = '' | ||
44 | sed -i \ | ||
45 | -e "s|RCUBE_INSTALL_PATH . 'temp.*|'${varDir}/cache';|" \ | ||
46 | config/defaults.inc.php | ||
47 | sed -i \ | ||
48 | -e "s|RCUBE_INSTALL_PATH . 'logs.*|'${varDir}/logs';|" \ | ||
49 | config/defaults.inc.php | ||
50 | ''; | ||
51 | installPhase = '' | ||
52 | cp -a . $out | ||
53 | ln -s ${roundcube_config} $out/config/config.inc.php | ||
54 | ''; | ||
55 | passthru = { | ||
56 | plugins = []; | ||
57 | skins = []; | ||
58 | inherit withPlugins buildPlugin; | ||
59 | }; | ||
60 | }; | ||
61 | in package | ||
diff --git a/pkgs/webapps/roundcubemail/plugins/automatic_addressbook/default.nix b/pkgs/webapps/roundcubemail/plugins/automatic_addressbook/default.nix new file mode 100644 index 00000000..cd9efee6 --- /dev/null +++ b/pkgs/webapps/roundcubemail/plugins/automatic_addressbook/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "automatic_addressbook"; | ||
4 | version = "0.4.3"; | ||
5 | url = "https://github.com/sblaisot/${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "0bx5qjzp3a3wc72fr295bvgsy5n15949c041hq76n6c7sqdn7inc"; | ||
7 | } | ||
diff --git a/pkgs/webapps/roundcubemail/plugins/carddav/default.nix b/pkgs/webapps/roundcubemail/plugins/carddav/default.nix new file mode 100644 index 00000000..ad6856bf --- /dev/null +++ b/pkgs/webapps/roundcubemail/plugins/carddav/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "carddav"; | ||
4 | version = "3.0.3"; | ||
5 | url = "https://github.com/blind-coder/rcmcarddav/releases/download/v${version}/${appName}-${version}.tar.bz2"; | ||
6 | sha256 = "0cf5rnqkhhag2vdy808zfpr4l5586fn43nvcia8ac1ha58azrxal"; | ||
7 | } | ||
diff --git a/pkgs/webapps/roundcubemail/plugins/contextmenu/default.nix b/pkgs/webapps/roundcubemail/plugins/contextmenu/default.nix new file mode 100644 index 00000000..c970007e --- /dev/null +++ b/pkgs/webapps/roundcubemail/plugins/contextmenu/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "contextmenu"; | ||
4 | version = "2.3"; | ||
5 | url = "https://github.com/johndoh/roundcube-${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "1rb8n821ylfniiiccfskc534vd6rczhk3g82455ks3m09q6l8hif"; | ||
7 | } | ||
diff --git a/pkgs/webapps/roundcubemail/plugins/contextmenu_folder/default.nix b/pkgs/webapps/roundcubemail/plugins/contextmenu_folder/default.nix new file mode 100644 index 00000000..e5cb46d7 --- /dev/null +++ b/pkgs/webapps/roundcubemail/plugins/contextmenu_folder/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "contextmenu_folder"; | ||
4 | version = "1.3.3"; | ||
5 | url = "https://github.com/random-cuber/${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "1ngfws1v8qrpa52rjh7kirc98alchk2vbqwra86h00agyjjlcc57"; | ||
7 | } | ||
diff --git a/pkgs/webapps/roundcubemail/plugins/html5_notifier/default.nix b/pkgs/webapps/roundcubemail/plugins/html5_notifier/default.nix new file mode 100644 index 00000000..35bff069 --- /dev/null +++ b/pkgs/webapps/roundcubemail/plugins/html5_notifier/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "html5_notifier"; | ||
4 | version = "v0.6.2"; | ||
5 | url = "https://github.com/stremlau/${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "0s1wq9ira4bcd8jvhn93nhxiqzpp92i0za2kw37kf7ksyhr0xslq"; | ||
7 | } | ||
diff --git a/pkgs/webapps/roundcubemail/plugins/ident_switch/default.nix b/pkgs/webapps/roundcubemail/plugins/ident_switch/default.nix new file mode 100644 index 00000000..1dfc4020 --- /dev/null +++ b/pkgs/webapps/roundcubemail/plugins/ident_switch/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "ident_switch"; | ||
4 | version = "4.0.1"; | ||
5 | url = "https://bitbucket.org/BoresExpress/${appName}/get/${version}.tar.gz"; | ||
6 | sha256 = "1zyy40lfq2kn7hkghbl8lgp18fb634zr4fxmmxvb1wqyvqdpdpyk"; | ||
7 | } | ||
diff --git a/pkgs/webapps/roundcubemail/plugins/message_highlight/default.nix b/pkgs/webapps/roundcubemail/plugins/message_highlight/default.nix new file mode 100644 index 00000000..dc7138ac --- /dev/null +++ b/pkgs/webapps/roundcubemail/plugins/message_highlight/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "message_highlight"; | ||
4 | version = "4.4"; | ||
5 | url = "https://github.com/corbosman/${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "12c4x47y70xdl5pgm8csh5i4yiyhpi232lvjbixmca6di4lkhh9j"; | ||
7 | } | ||
diff --git a/pkgs/webapps/roundcubemail/plugins/thunderbird_labels/default.nix b/pkgs/webapps/roundcubemail/plugins/thunderbird_labels/default.nix new file mode 100644 index 00000000..ca7245f5 --- /dev/null +++ b/pkgs/webapps/roundcubemail/plugins/thunderbird_labels/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "thunderbird_labels"; | ||
4 | version = "v1.3.2"; | ||
5 | url = "https://github.com/mike-kfed/roundcube-${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "1q4x30w66m02v3lw2n8020g0158rmyfzs6gydfk89pa1hs28k9bg"; | ||
7 | } | ||