summaryrefslogtreecommitdiff
path: root/pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2018-12-13 21:25:24 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-24 01:40:13 +0200
commit24fd1fe6c62b7a9fc347794fde043285da272f5c (patch)
tree65557bf1d241ca389b619dbd24d18d51932ee030 /pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix
downloadNUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.gz
NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.zst
NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.zip
Initial commit published for NUR
Diffstat (limited to 'pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix')
-rw-r--r--pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix b/pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix
new file mode 100644
index 00000000..dc6c7de0
--- /dev/null
+++ b/pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix
@@ -0,0 +1,21 @@
1{ stdenv, fetchFromGitHub }:
2stdenv.mkDerivation rec {
3 version = "v2.2.0";
4 name = "mantisbt-plugin-source-integration-${version}";
5 src = fetchFromGitHub {
6 owner = "mantisbt-plugins";
7 repo = "source-integration";
8 rev = "44fc9e2e770aff4f40f56833f26a86ce0e2deb76";
9 sha256 = "0gcm6kqqijnv303sk59zn27adwx5vkr545mwzyaq2nrpxnkwdy5b";
10 };
11 patches = [
12 ./Source.API.php.diff
13 ];
14 installPhase = ''
15 mkdir $out
16 cp -a Source* $out/
17 '';
18 passthru = {
19 selector = "Source*";
20 };
21}