diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2018-12-13 21:25:24 +0100 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-05-24 01:40:13 +0200 |
commit | 24fd1fe6c62b7a9fc347794fde043285da272f5c (patch) | |
tree | 65557bf1d241ca389b619dbd24d18d51932ee030 /pkgs/webapps/default.nix | |
download | NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.gz NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.zst NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.zip |
Initial commit published for NUR
Diffstat (limited to 'pkgs/webapps/default.nix')
-rw-r--r-- | pkgs/webapps/default.nix | 114 |
1 files changed, 114 insertions, 0 deletions
diff --git a/pkgs/webapps/default.nix b/pkgs/webapps/default.nix new file mode 100644 index 00000000..8c3eb0ef --- /dev/null +++ b/pkgs/webapps/default.nix | |||
@@ -0,0 +1,114 @@ | |||
1 | { callPackage, mylibs, composerEnv, lib, private }: | ||
2 | rec { | ||
3 | adminer = callPackage ./adminer {}; | ||
4 | apache-theme = callPackage ./apache-theme {}; | ||
5 | awl = callPackage ./awl {}; | ||
6 | davical = callPackage ./davical {}; | ||
7 | diaspora = callPackage ./diaspora { inherit mylibs; }; | ||
8 | |||
9 | dokuwiki = callPackage ./dokuwiki { inherit mylibs; }; | ||
10 | dokuwiki-with-plugins = dokuwiki.withPlugins (builtins.attrValues dokuwiki-plugins); | ||
11 | dokuwiki-plugins = let | ||
12 | names = [ "farmer" "todo" ]; | ||
13 | in | ||
14 | lib.attrsets.genAttrs names | ||
15 | (name: callPackage (./dokuwiki/plugins + "/${name}.nix") {}); | ||
16 | |||
17 | etherpad-lite = callPackage ./etherpad-lite {}; | ||
18 | etherpad-lite-with-modules = etherpad-lite.withModules (builtins.attrValues etherpad-lite-modules); | ||
19 | etherpad-lite-modules = let | ||
20 | nodeEnv = callPackage mylibs.nodeEnv {}; | ||
21 | names = [ | ||
22 | "ep_aa_file_menu_toolbar" "ep_adminpads" "ep_align" "ep_bookmark" | ||
23 | "ep_clear_formatting" "ep_colors" "ep_copy_paste_select_all" | ||
24 | "ep_cursortrace" "ep_embedmedia" "ep_font_family" "ep_font_size" | ||
25 | "ep_headings2" "ep_ldapauth" "ep_line_height" "ep_markdown" | ||
26 | "ep_previewimages" "ep_ruler" "ep_scrollto" "ep_set_title_on_pad" | ||
27 | "ep_subscript_and_superscript" "ep_timesliderdiff" | ||
28 | ]; | ||
29 | in | ||
30 | # nix files are built using node2nix -i node-packages.json | ||
31 | lib.attrsets.genAttrs names | ||
32 | (name: (callPackage (./etherpad-lite/modules + "/${name}/node-packages.nix") { inherit nodeEnv; }) | ||
33 | .${name}.overrideAttrs(old: { passthru = (old.passthru or {}) // { moduleName = name; }; })); | ||
34 | |||
35 | infcloud = callPackage ./infcloud {}; | ||
36 | |||
37 | mantisbt_2 = callPackage ./mantisbt_2 {}; | ||
38 | mantisbt_2-with-plugins = mantisbt_2.withPlugins (builtins.attrValues mantisbt_2-plugins); | ||
39 | mantisbt_2-plugins = let | ||
40 | names = [ "slack" "source-integration" ]; | ||
41 | in | ||
42 | lib.attrsets.genAttrs names | ||
43 | (name: callPackage (./mantisbt_2/plugins + "/${name}") {}); | ||
44 | |||
45 | mastodon = callPackage ./mastodon { inherit mylibs; }; | ||
46 | |||
47 | mediagoblin = callPackage ./mediagoblin { inherit mylibs; }; | ||
48 | mediagoblin-with-plugins = mediagoblin.withPlugins (builtins.attrValues mediagoblin-plugins); | ||
49 | mediagoblin-plugins = let | ||
50 | names = [ "basicsearch" ]; | ||
51 | in | ||
52 | lib.attrsets.genAttrs names | ||
53 | (name: callPackage (./mediagoblin/plugins + "/${name}") {}); | ||
54 | |||
55 | nextcloud = callPackage ./nextcloud {}; | ||
56 | nextcloud-with-apps = nextcloud.withPlugins (builtins.attrValues nextcloud-apps); | ||
57 | nextcloud-apps = let | ||
58 | names = [ | ||
59 | "audioplayer" "bookmarks" "calendar" "contacts" "deck" | ||
60 | "files_markdown" "gpxedit" "gpxpod" "keeweb" "music" | ||
61 | "notes" "ocsms" "passman" "spreed" "tasks" | ||
62 | "flowupload" "carnet" | ||
63 | # FIXME: fix passman for NC 16 | ||
64 | ]; | ||
65 | in | ||
66 | lib.attrsets.genAttrs names | ||
67 | (name: callPackage (./nextcloud/apps + "/${name}.nix") { buildApp = nextcloud.buildApp; }); | ||
68 | |||
69 | peertube = callPackage ./peertube { inherit mylibs; }; | ||
70 | phpldapadmin = callPackage ./phpldapadmin {}; | ||
71 | rompr = callPackage ./rompr { inherit mylibs; }; | ||
72 | |||
73 | roundcubemail = callPackage ./roundcubemail {}; | ||
74 | roundcubemail-with-plugins-skins = roundcubemail.withPlugins (builtins.attrValues roundcubemail-plugins) (builtins.attrValues roundcubemail-skins); | ||
75 | roundcubemail-skins = let | ||
76 | names = []; | ||
77 | in | ||
78 | lib.attrsets.genAttrs names | ||
79 | (name: callPackage (./roundcubemail/skins + "/${name}") {}); | ||
80 | roundcubemail-plugins = let | ||
81 | names = [ | ||
82 | "automatic_addressbook" "carddav" "contextmenu" | ||
83 | "contextmenu_folder" "html5_notifier" "ident_switch" | ||
84 | "message_highlight" "thunderbird_labels" | ||
85 | ]; | ||
86 | in | ||
87 | lib.attrsets.genAttrs names | ||
88 | (name: callPackage (./roundcubemail/plugins + "/${name}") { buildPlugin = roundcubemail.buildPlugin; }); | ||
89 | |||
90 | spip = callPackage ./spip {}; | ||
91 | taskwarrior-web = callPackage ./taskwarrior-web { inherit mylibs; }; | ||
92 | |||
93 | ttrss = callPackage ./ttrss { inherit mylibs; }; | ||
94 | ttrss-with-plugins = ttrss.withPlugins (builtins.attrValues ttrss-plugins); | ||
95 | ttrss-plugins = let | ||
96 | names = [ "auth_ldap" "af_feedmod" "feediron" "ff_instagram" "tumblr_gdpr_ua" ]; | ||
97 | patched = [ "af_feedmod" "feediron" ]; | ||
98 | in | ||
99 | lib.attrsets.genAttrs names | ||
100 | (name: callPackage (./ttrss/plugins + "/${name}") ( | ||
101 | { inherit mylibs; } // | ||
102 | (if builtins.elem name patched then { patched = true; } else {}) | ||
103 | ) | ||
104 | ); | ||
105 | |||
106 | wallabag = callPackage ./wallabag { inherit composerEnv; }; | ||
107 | yourls = callPackage ./yourls { inherit mylibs; }; | ||
108 | yourls-with-plugins = yourls.withPlugins (builtins.attrValues yourls-plugins); | ||
109 | yourls-plugins = let | ||
110 | names = [ "ldap" ]; | ||
111 | in | ||
112 | lib.attrsets.genAttrs names | ||
113 | (name: callPackage (./yourls/plugins + "/${name}") { inherit mylibs; }); | ||
114 | } // private.webapps | ||