diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2018-12-13 21:25:24 +0100 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-05-24 01:40:13 +0200 |
commit | 252dd7d899b7a0deea1537cc5d2d48b825afffb0 (patch) | |
tree | f51c3c9cd7429b0b9553a840f26bee489be045bc /pkgs/telegram-cli | |
download | NUR-252dd7d899b7a0deea1537cc5d2d48b825afffb0.tar.gz NUR-252dd7d899b7a0deea1537cc5d2d48b825afffb0.tar.zst NUR-252dd7d899b7a0deea1537cc5d2d48b825afffb0.zip |
Initial commit published for NURnur_root
Diffstat (limited to 'pkgs/telegram-cli')
-rw-r--r-- | pkgs/telegram-cli/default.nix | 16 | ||||
-rw-r--r-- | pkgs/telegram-cli/telegram-cli.json | 15 | ||||
-rw-r--r-- | pkgs/telegram-cli/telegram-cli.patch | 90 |
3 files changed, 121 insertions, 0 deletions
diff --git a/pkgs/telegram-cli/default.nix b/pkgs/telegram-cli/default.nix new file mode 100644 index 00000000..6987748d --- /dev/null +++ b/pkgs/telegram-cli/default.nix | |||
@@ -0,0 +1,16 @@ | |||
1 | { stdenv, mylibs, pkgconfig, libevent, lua, jansson, openssl, readline, zlib, libconfig }: | ||
2 | stdenv.mkDerivation (mylibs.fetchedGithub ./telegram-cli.json // { | ||
3 | patches = [ | ||
4 | ./telegram-cli.patch | ||
5 | ]; | ||
6 | buildInputs = [ pkgconfig libevent lua jansson openssl readline zlib libconfig ]; | ||
7 | preBuild = '' | ||
8 | sed -i -e 's@"/etc/" PROG_NAME "/server.pub"@"'$out'/etc/server.pub"@' main.c | ||
9 | ''; | ||
10 | installPhase = '' | ||
11 | mkdir -p $out | ||
12 | install -Dm755 bin/telegram-cli $out/bin/telegram-cli | ||
13 | install -Dm644 tg-server.pub $out/etc/server.pub | ||
14 | install -Dm644 debian/telegram-cli.8 $out/man/man8/telegram-cli.8 | ||
15 | ''; | ||
16 | }) | ||
diff --git a/pkgs/telegram-cli/telegram-cli.json b/pkgs/telegram-cli/telegram-cli.json new file mode 100644 index 00000000..53e0a7b2 --- /dev/null +++ b/pkgs/telegram-cli/telegram-cli.json | |||
@@ -0,0 +1,15 @@ | |||
1 | { | ||
2 | "tag": "6547c0b-master", | ||
3 | "meta": { | ||
4 | "name": "telegram-cli", | ||
5 | "url": "https://github.com/vysheng/tg", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "vysheng", | ||
10 | "repo": "tg", | ||
11 | "rev": "6547c0b21b977b327b3c5e8142963f4bc246187a", | ||
12 | "sha256": "07sss5cnw2ygd7mp8f5532lmj7qm6ywqf4cjaq5g13i8igzqzwzj", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||
diff --git a/pkgs/telegram-cli/telegram-cli.patch b/pkgs/telegram-cli/telegram-cli.patch new file mode 100644 index 00000000..2d2b7b04 --- /dev/null +++ b/pkgs/telegram-cli/telegram-cli.patch | |||
@@ -0,0 +1,90 @@ | |||
1 | diff --git a/tgl/crypto/rsa_pem_openssl.c b/tgl/crypto/rsa_pem_openssl.c | ||
2 | index db653f2..5e6a697 100644 | ||
3 | --- a/tgl/crypto/rsa_pem_openssl.c | ||
4 | +++ b/tgl/crypto/rsa_pem_openssl.c | ||
5 | @@ -36,6 +36,12 @@ TGLC_WRAPPER_ASSOC(rsa,RSA) | ||
6 | // TODO: Refactor crucial struct-identity into its own header. | ||
7 | TGLC_WRAPPER_ASSOC(bn,BIGNUM) | ||
8 | |||
9 | +/* | ||
10 | + * Since OpenSSL version 1.1.0 the RSA struct (rsa_st) is opaque, | ||
11 | + * see also https://wiki.openssl.org/index.php/OpenSSL_1.1.0_Changes | ||
12 | + */ | ||
13 | +#if (OPENSSL_VERSION_NUMBER < 0x10100000L) | ||
14 | + | ||
15 | TGLC_rsa *TGLC_rsa_new (unsigned long e, int n_bytes, const unsigned char *n) { | ||
16 | RSA *ret = RSA_new (); | ||
17 | ret->e = unwrap_bn (TGLC_bn_new ()); | ||
18 | @@ -47,7 +53,30 @@ TGLC_rsa *TGLC_rsa_new (unsigned long e, int n_bytes, const unsigned char *n) { | ||
19 | #define RSA_GETTER(M) \ | ||
20 | TGLC_bn *TGLC_rsa_ ## M (TGLC_rsa *key) { \ | ||
21 | return wrap_bn (unwrap_rsa (key)->M); \ | ||
22 | - } \ | ||
23 | + } | ||
24 | + | ||
25 | +#else // OPENSSL_VERSION_NUMBER | ||
26 | + | ||
27 | +TGLC_rsa *TGLC_rsa_new (unsigned long e, int n_bytes, const unsigned char *n) { | ||
28 | + RSA *ret = RSA_new (); | ||
29 | + BIGNUM *ret_e = unwrap_bn (TGLC_bn_new ()); | ||
30 | + BIGNUM *ret_n = unwrap_bn (TGLC_bn_bin2bn (n, n_bytes, NULL)); | ||
31 | + RSA_set0_key (ret, ret_n, ret_e, NULL); | ||
32 | + TGLC_bn_set_word (wrap_bn (ret_e), e); | ||
33 | + return wrap_rsa (ret); | ||
34 | +} | ||
35 | + | ||
36 | +#define RSA_GETTER(M) \ | ||
37 | +TGLC_bn *TGLC_rsa_ ## M (TGLC_rsa *key) { \ | ||
38 | + BIGNUM *rsa_n, *rsa_e, *rsa_d; \ | ||
39 | + RSA_get0_key(unwrap_rsa (key), \ | ||
40 | + (const BIGNUM **) &rsa_n, \ | ||
41 | + (const BIGNUM **) &rsa_e, \ | ||
42 | + (const BIGNUM **) &rsa_d); \ | ||
43 | + return wrap_bn (rsa_ ## M); \ | ||
44 | +} | ||
45 | + | ||
46 | +#endif // OPENSSL_VERSION_NUMBER | ||
47 | |||
48 | RSA_GETTER(n); | ||
49 | RSA_GETTER(e); | ||
50 | @@ -60,4 +89,4 @@ TGLC_rsa *TGLC_pem_read_RSAPublicKey (FILE *fp) { | ||
51 | return wrap_rsa (PEM_read_RSAPublicKey (fp, NULL, NULL, NULL)); | ||
52 | } | ||
53 | |||
54 | -#endif | ||
55 | +#endif // TGL_AVOID_OPENSSL | ||
56 | diff --git a/tgl/mtproto-utils.c b/tgl/mtproto-utils.c | ||
57 | index 0948bc8..cfdb216 100644 | ||
58 | --- a/tgl/mtproto-utils.c | ||
59 | +++ b/tgl/mtproto-utils.c | ||
60 | @@ -98,7 +98,7 @@ static unsigned long long BN2ull (TGLC_bn *b) { | ||
61 | if (sizeof (unsigned long) == 8) { | ||
62 | return TGLC_bn_get_word (b); | ||
63 | } else if (sizeof (unsigned long long) == 8) { | ||
64 | - assert (0); // As long as nobody ever uses this code, assume it is broken. | ||
65 | +// assert (0); // As long as nobody ever uses this code, assume it is broken. | ||
66 | unsigned long long tmp; | ||
67 | /* Here be dragons, but it should be okay due to be64toh */ | ||
68 | TGLC_bn_bn2bin (b, (unsigned char *) &tmp); | ||
69 | @@ -112,7 +112,7 @@ static void ull2BN (TGLC_bn *b, unsigned long long val) { | ||
70 | if (sizeof (unsigned long) == 8 || val < (1ll << 32)) { | ||
71 | TGLC_bn_set_word (b, val); | ||
72 | } else if (sizeof (unsigned long long) == 8) { | ||
73 | - assert (0); // As long as nobody ever uses this code, assume it is broken. | ||
74 | +// assert (0); // As long as nobody ever uses this code, assume it is broken. | ||
75 | htobe64(val); | ||
76 | /* Here be dragons, but it should be okay due to htobe64 */ | ||
77 | TGLC_bn_bin2bn ((unsigned char *) &val, 8, b); | ||
78 | diff --git a/tgl/tl-parser/tl-parser.c b/tgl/tl-parser/tl-parser.c | ||
79 | index 524b196..aeadbd2 100644 | ||
80 | --- a/tgl/tl-parser/tl-parser.c | ||
81 | +++ b/tgl/tl-parser/tl-parser.c | ||
82 | @@ -1903,7 +1903,7 @@ struct tl_combinator_tree *tl_parse_args134 (struct tree *T) { | ||
83 | //assert (S->data); | ||
84 | char *name = S->data; | ||
85 | if (!name) { | ||
86 | - static char s[20]; | ||
87 | + static char s[21]; | ||
88 | sprintf (s, "%lld", lrand48 () * (1ll << 32) + lrand48 ()); | ||
89 | name = s; | ||
90 | } | ||