summaryrefslogtreecommitdiff
path: root/pkgs/python-packages/apprise
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2018-12-13 21:25:24 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-24 01:40:13 +0200
commit24fd1fe6c62b7a9fc347794fde043285da272f5c (patch)
tree65557bf1d241ca389b619dbd24d18d51932ee030 /pkgs/python-packages/apprise
downloadNUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.gz
NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.zst
NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.zip
Initial commit published for NUR
Diffstat (limited to 'pkgs/python-packages/apprise')
-rw-r--r--pkgs/python-packages/apprise/apprise.json15
-rw-r--r--pkgs/python-packages/apprise/default.nix11
2 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/python-packages/apprise/apprise.json b/pkgs/python-packages/apprise/apprise.json
new file mode 100644
index 00000000..b408ea49
--- /dev/null
+++ b/pkgs/python-packages/apprise/apprise.json
@@ -0,0 +1,15 @@
1{
2 "tag": "c9b957c-master",
3 "meta": {
4 "name": "apprise",
5 "url": "https://github.com/caronc/apprise",
6 "branch": "master"
7 },
8 "github": {
9 "owner": "caronc",
10 "repo": "apprise",
11 "rev": "c9b957c4341e7d43e5be6463bd317a7401d083d9",
12 "sha256": "01zz4mh3xvplrm5xalzrcncnh0jq5y51pmdxkr4hdd6dz9wx0mbg",
13 "fetchSubmodules": true
14 }
15}
diff --git a/pkgs/python-packages/apprise/default.nix b/pkgs/python-packages/apprise/default.nix
new file mode 100644
index 00000000..d310599e
--- /dev/null
+++ b/pkgs/python-packages/apprise/default.nix
@@ -0,0 +1,11 @@
1{ mylibs, pythonPackages }: with pythonPackages;
2buildPythonPackage rec {
3 pname = "apprise";
4 version = "0.7.4";
5 src = (mylibs.fetchedGithub ./apprise.json).src;
6 propagatedBuildInputs = [ decorator requests
7 requests_oauthlib oauthlib urllib3 six click markdown pyyaml
8 sleekxmpp
9 ];
10 doChecks = false;
11}