summaryrefslogtreecommitdiff
path: root/pkgs/openarc/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-06-04 09:53:11 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-04-25 00:04:24 +0200
commit2b96efc8a4b287509c38509d44988f32a179a001 (patch)
treecdd0671badddde368f51510eac9ee2b20ff6073e /pkgs/openarc/default.nix
parentfb7f2ad86ebdee514b3b361aa5615e333ac66780 (diff)
downloadNUR-2b96efc8a4b287509c38509d44988f32a179a001.tar.gz
NUR-2b96efc8a4b287509c38509d44988f32a179a001.tar.zst
NUR-2b96efc8a4b287509c38509d44988f32a179a001.zip
Add opendmarc openarc and opendkim configuration and packages
Diffstat (limited to 'pkgs/openarc/default.nix')
-rw-r--r--pkgs/openarc/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/openarc/default.nix b/pkgs/openarc/default.nix
new file mode 100644
index 00000000..e5c9a81c
--- /dev/null
+++ b/pkgs/openarc/default.nix
@@ -0,0 +1,18 @@
1{ stdenv, autoconf, automake, file, libtool, libbsd, mylibs, openssl, pkg-config, libmilter }:
2
3stdenv.mkDerivation (mylibs.fetchedGithub ./openarc.json // rec {
4 buildInputs = [ automake autoconf libbsd libtool openssl pkg-config libmilter ];
5
6 configureFlags = [
7 "--with-milter=${libmilter}"
8 ];
9 preConfigure = ''
10 autoreconf --force --install
11 sed -i -e "s@/usr/bin/file@${file}/bin/file@" ./configure
12 '';
13 meta = with stdenv.lib; {
14 description = "Open source ARC implementation";
15 homepage = https://github.com/trusteddomainproject/OpenARC;
16 platforms = platforms.unix;
17 };
18})