diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2018-12-13 21:25:24 +0100 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-05-24 01:40:13 +0200 |
commit | 24fd1fe6c62b7a9fc347794fde043285da272f5c (patch) | |
tree | 65557bf1d241ca389b619dbd24d18d51932ee030 /pkgs/notmuch | |
download | NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.gz NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.zst NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.zip |
Initial commit published for NUR
Diffstat (limited to 'pkgs/notmuch')
-rw-r--r-- | pkgs/notmuch/notmuch-python/default.nix | 16 | ||||
-rw-r--r-- | pkgs/notmuch/notmuch-vim/default.nix | 11 |
2 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/notmuch/notmuch-python/default.nix b/pkgs/notmuch/notmuch-python/default.nix new file mode 100644 index 00000000..d639d9ae --- /dev/null +++ b/pkgs/notmuch/notmuch-python/default.nix | |||
@@ -0,0 +1,16 @@ | |||
1 | { stdenv, notmuch, pythonPackages }: | ||
2 | stdenv.mkDerivation rec { | ||
3 | name = "notmuch-${pythonPackages.python.name}-${version}"; | ||
4 | version = notmuch.version; | ||
5 | outputs = [ "out" ]; | ||
6 | buildInputs = with pythonPackages; [ sphinx python ]; | ||
7 | src = notmuch.src; | ||
8 | phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ]; | ||
9 | buildPhase = '' | ||
10 | cd bindings/python | ||
11 | python setup.py build | ||
12 | ''; | ||
13 | installPhase = '' | ||
14 | python setup.py install --prefix=$out --optimize=1 | ||
15 | ''; | ||
16 | } | ||
diff --git a/pkgs/notmuch/notmuch-vim/default.nix b/pkgs/notmuch/notmuch-vim/default.nix new file mode 100644 index 00000000..e79a253a --- /dev/null +++ b/pkgs/notmuch/notmuch-vim/default.nix | |||
@@ -0,0 +1,11 @@ | |||
1 | { stdenv, notmuch }: | ||
2 | stdenv.mkDerivation rec { | ||
3 | name = "notmuch-vim-${version}"; | ||
4 | version = notmuch.version; | ||
5 | outputs = [ "out" ]; | ||
6 | src = notmuch.src; | ||
7 | phases = [ "unpackPhase" "installPhase" ]; | ||
8 | installPhase = '' | ||
9 | make -C vim DESTDIR=$out prefix="/share/vim/vimfiles" install | ||
10 | ''; | ||
11 | } | ||