diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2018-12-13 21:25:24 +0100 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-05-24 01:40:13 +0200 |
commit | 24fd1fe6c62b7a9fc347794fde043285da272f5c (patch) | |
tree | 65557bf1d241ca389b619dbd24d18d51932ee030 /pkgs/cnagios | |
download | NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.gz NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.zst NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.zip |
Initial commit published for NUR
Diffstat (limited to 'pkgs/cnagios')
-rw-r--r-- | pkgs/cnagios/cnagios.json | 15 | ||||
-rw-r--r-- | pkgs/cnagios/default.nix | 22 |
2 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/cnagios/cnagios.json b/pkgs/cnagios/cnagios.json new file mode 100644 index 00000000..4c1c385a --- /dev/null +++ b/pkgs/cnagios/cnagios.json | |||
@@ -0,0 +1,15 @@ | |||
1 | { | ||
2 | "tag": "3bd27fb-master", | ||
3 | "meta": { | ||
4 | "name": "cnagios", | ||
5 | "url": "https://github.com/dannywarren/cnagios", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "dannywarren", | ||
10 | "repo": "cnagios", | ||
11 | "rev": "3bd27fb40e68f61ffd01bea6234b919a667b6fe4", | ||
12 | "sha256": "0iy5pmlcz6y3if72nav22xqxniiv1v8ywi0927m6s459hkw5n2rb", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||
diff --git a/pkgs/cnagios/default.nix b/pkgs/cnagios/default.nix new file mode 100644 index 00000000..d5b52f3f --- /dev/null +++ b/pkgs/cnagios/default.nix | |||
@@ -0,0 +1,22 @@ | |||
1 | { stdenv, mylibs, perl, ncurses }: | ||
2 | stdenv.mkDerivation (mylibs.fetchedGithub ./cnagios.json // { | ||
3 | configureFlags = [ | ||
4 | "--with-etc-dir=/etc/cnagios" | ||
5 | "--with-var-dir=/var/lib/naemon" | ||
6 | "--with-status-file=/var/lib/naemon/status.dat" | ||
7 | "--with-nagios-data=4" | ||
8 | ]; | ||
9 | |||
10 | prePatch = '' | ||
11 | sed -i -e "s/-lcurses/-lncurses/" Makefile.in | ||
12 | ''; | ||
13 | installPhase = '' | ||
14 | install -dm755 $out/share/doc/cnagios | ||
15 | install -Dm644 cnagiosrc $out/share/doc/cnagios/ | ||
16 | install -Dm644 cnagios.help $out/share/doc/cnagios/ | ||
17 | install -Dm644 cnagios.pl $out/share/doc/cnagios/ | ||
18 | install -dm755 $out/bin | ||
19 | install -Dm755 cnagios $out/bin/ | ||
20 | ''; | ||
21 | buildInputs = [ perl ncurses ]; | ||
22 | }) | ||