summaryrefslogtreecommitdiff
path: root/pkgs/boinctui
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2018-12-13 21:25:24 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-24 01:40:13 +0200
commit24fd1fe6c62b7a9fc347794fde043285da272f5c (patch)
tree65557bf1d241ca389b619dbd24d18d51932ee030 /pkgs/boinctui
downloadNUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.gz
NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.zst
NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.zip
Initial commit published for NUR
Diffstat (limited to 'pkgs/boinctui')
-rw-r--r--pkgs/boinctui/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/pkgs/boinctui/default.nix b/pkgs/boinctui/default.nix
new file mode 100644
index 00000000..d8b106a3
--- /dev/null
+++ b/pkgs/boinctui/default.nix
@@ -0,0 +1,20 @@
1{ stdenv, fetchurl, expat, openssl, autoconf, ncurses }:
2stdenv.mkDerivation rec {
3 name = "boinctui-${version}";
4 version = "2.5.0";
5 src = fetchurl {
6 url = "http://sourceforge.net/projects/boinctui/files/boinctui_${version}.tar.gz";
7 sha256 = "16zxp8r4z6pllacdacg681y56cg2phnn3pm5gwszbsi93cix2g8p";
8 };
9
10 configureFlags = [ "--without-gnutls" ];
11 preConfigure = ''
12 autoconf
13 '';
14
15 preBuild = ''
16 sed -i -e 's/"HOME"/"XDG_CONFIG_HOME"/' src/cfg.cpp
17 sed -i -e 's@\.boinctui\.cfg@boinctui/boinctui.cfg@' src/mainprog.cpp
18 '';
19 buildInputs = [ expat openssl autoconf ncurses ];
20}