summaryrefslogtreecommitdiff
path: root/overlays/databases/postgresql/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2018-12-13 21:25:24 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-24 01:40:13 +0200
commit24fd1fe6c62b7a9fc347794fde043285da272f5c (patch)
tree65557bf1d241ca389b619dbd24d18d51932ee030 /overlays/databases/postgresql/default.nix
downloadNUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.gz
NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.tar.zst
NUR-24fd1fe6c62b7a9fc347794fde043285da272f5c.zip
Initial commit published for NUR
Diffstat (limited to 'overlays/databases/postgresql/default.nix')
-rw-r--r--overlays/databases/postgresql/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/overlays/databases/postgresql/default.nix b/overlays/databases/postgresql/default.nix
new file mode 100644
index 00000000..8d1405e3
--- /dev/null
+++ b/overlays/databases/postgresql/default.nix
@@ -0,0 +1,11 @@
1self: super: rec {
2 postgresql_11_custom = super.postgresql_11.overrideAttrs(old: {
3 # datadir in /var/lib/postgresql is named after psqlSchema
4 passthru = old.passthru // { psqlSchema = "11.0"; };
5 configureFlags = old.configureFlags ++ [ "--with-pam" ];
6 buildInputs = (old.buildInputs or []) ++ [ self.pam ];
7 patches = old.patches ++ [
8 ./postgresql_run_socket_path.patch
9 ];
10 });
11}