summaryrefslogtreecommitdiff
path: root/modules/websites/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-06-02 09:48:05 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-04-25 00:04:24 +0200
commit55ebe7be7375fe58c5e8a6f8edc31f768ddf5e6f (patch)
treee07198a00432246bd248478760b8b0bc16fea146 /modules/websites/default.nix
parent589aeb9297f6f2a99b98c07cb9a834bb5e25b9f0 (diff)
downloadNUR-55ebe7be7375fe58c5e8a6f8edc31f768ddf5e6f.tar.gz
NUR-55ebe7be7375fe58c5e8a6f8edc31f768ddf5e6f.tar.zst
NUR-55ebe7be7375fe58c5e8a6f8edc31f768ddf5e6f.zip
Finish moving aten php configuration to dedicated module
Diffstat (limited to 'modules/websites/default.nix')
-rw-r--r--modules/websites/default.nix19
1 files changed, 11 insertions, 8 deletions
diff --git a/modules/websites/default.nix b/modules/websites/default.nix
index ef79cb3c..043fc6ec 100644
--- a/modules/websites/default.nix
+++ b/modules/websites/default.nix
@@ -23,14 +23,6 @@ in
23 Name of the webapp dir to create in /run/current-system 23 Name of the webapp dir to create in /run/current-system
24 ''; 24 '';
25 }; 25 };
26 webappDirsPath = mkOption {
27 type = str;
28 readOnly = true;
29 description = ''
30 Full path of the webapp dir
31 '';
32 default = "/run/current-system/${cfg.webappDirsName}";
33 };
34 env = mkOption { 26 env = mkOption {
35 default = {}; 27 default = {};
36 description = "Each type of website to enable will target a distinct httpd server"; 28 description = "Each type of website to enable will target a distinct httpd server";
@@ -126,6 +118,17 @@ in
126 }; 118 };
127 }); 119 });
128 }; 120 };
121 # Readonly variables
122 webappDirsPaths = mkOption {
123 type = attrsOf path;
124 readOnly = true;
125 description = ''
126 Full paths of the webapp dir
127 '';
128 default = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
129 name "/run/current-system/${cfg.webappDirsName}/${name}"
130 ) cfg.webappDirs;
131 };
129 }; 132 };
130 133
131 config.services.httpd = let 134 config.services.httpd = let