summaryrefslogtreecommitdiff
path: root/modules/private/mail.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2018-12-13 21:25:24 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-24 01:40:13 +0200
commit252dd7d899b7a0deea1537cc5d2d48b825afffb0 (patch)
treef51c3c9cd7429b0b9553a840f26bee489be045bc /modules/private/mail.nix
downloadNUR-nur_root.tar.gz
NUR-nur_root.tar.zst
NUR-nur_root.zip
Initial commit published for NURnur_root
Diffstat (limited to 'modules/private/mail.nix')
-rw-r--r--modules/private/mail.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/private/mail.nix b/modules/private/mail.nix
new file mode 100644
index 00000000..611c8b41
--- /dev/null
+++ b/modules/private/mail.nix
@@ -0,0 +1,13 @@
1{ lib, pkgs, config, myconfig, ... }:
2{
3 config.users.users.nullmailer.uid = config.ids.uids.nullmailer;
4 config.users.groups.nullmailer.gid = config.ids.gids.nullmailer;
5
6 config.services.nullmailer = {
7 enable = true;
8 config = {
9 me = myconfig.env.mail.host;
10 remotes = "${myconfig.env.mail.relay} smtp";
11 };
12 };
13}