aboutsummaryrefslogtreecommitdiff
path: root/systems/monitoring-1/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/monitoring-1/base.nix')
-rw-r--r--systems/monitoring-1/base.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/systems/monitoring-1/base.nix b/systems/monitoring-1/base.nix
index 8bfacc1..2d8139e 100644
--- a/systems/monitoring-1/base.nix
+++ b/systems/monitoring-1/base.nix
@@ -42,30 +42,6 @@
42 }) 42 })
43 ]; 43 ];
44 44
45 services.netdata.enable = true;
46 services.netdata.configDir."stream.conf" = config.secrets.fullPaths."netdata-stream.conf";
47 services.netdata.config.web."allow dashboard from" = "localhost";
48 services.netdata.config.web."allow badges from" = "*";
49 services.netdata.config.web."allow streaming from" = "*";
50 services.netdata.config.web."allow netdata.conf from" = "fd*";
51 services.netdata.config.web."allow management from" = "fd*";
52 networking.firewall.allowedTCPPorts = [ 19999 ];
53
54 secrets.keys = {
55 "netdata-stream.conf" = {
56 user = config.services.netdata.user;
57 group = config.services.netdata.group;
58 permissions = "0400";
59 text = builtins.concatStringsSep "\n" (pkgs.lib.mapAttrsToList (_: key: ''
60 [${key}]
61 enabled = yes
62 default history = 3600
63 default memory = ram
64 health enabled by default = auto
65 '') config.myEnv.monitoring.netdata_keys);
66 };
67 };
68 users.users."${config.services.netdata.user}".extraGroups = [ "keys" ];
69 # This value determines the NixOS release with which your system is 45 # This value determines the NixOS release with which your system is
70 # to be compatible, in order to avoid breaking some software such as 46 # to be compatible, in order to avoid breaking some software such as
71 # database servers. You should change this only after NixOS release 47 # database servers. You should change this only after NixOS release