aboutsummaryrefslogtreecommitdiff
path: root/systems/eldiron/websites/immae/production.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/eldiron/websites/immae/production.nix')
-rw-r--r--systems/eldiron/websites/immae/production.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/systems/eldiron/websites/immae/production.nix b/systems/eldiron/websites/immae/production.nix
index e4060ba..2ed4a7d 100644
--- a/systems/eldiron/websites/immae/production.nix
+++ b/systems/eldiron/websites/immae/production.nix
@@ -4,6 +4,7 @@ let
4 varDir = "/var/lib/buildbot/outputs/immae/blog"; 4 varDir = "/var/lib/buildbot/outputs/immae/blog";
5 historyDir = "/var/lib/buildbot/outputs/immae/history"; 5 historyDir = "/var/lib/buildbot/outputs/immae/history";
6 docsDir = "/var/lib/buildbot/outputs/immae/docs/"; 6 docsDir = "/var/lib/buildbot/outputs/immae/docs/";
7 patchesDir = "/var/lib/buildbot/outputs/immae/patches/";
7in { 8in {
8 options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website"; 9 options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
9 10
@@ -19,6 +20,7 @@ in {
19 security.acme.certs.immae.extraDomainNames = [ "immae.eu" ]; 20 security.acme.certs.immae.extraDomainNames = [ "immae.eu" ];
20 services.websites.env.production.bindMounts."${varDir}" = {}; 21 services.websites.env.production.bindMounts."${varDir}" = {};
21 services.websites.env.production.bindMounts."${docsDir}" = {}; 22 services.websites.env.production.bindMounts."${docsDir}" = {};
23 services.websites.env.production.bindMounts."${patchesDir}" = {};
22 services.websites.env.production.bindMounts."${historyDir}" = {}; 24 services.websites.env.production.bindMounts."${historyDir}" = {};
23 services.websites.env.production.vhostConfs.immae_production = { 25 services.websites.env.production.vhostConfs.immae_production = {
24 certName = "immae"; 26 certName = "immae";
@@ -56,6 +58,14 @@ in {
56 Header always set Access-Control-Allow-Origin "*" 58 Header always set Access-Control-Allow-Origin "*"
57 </Directory> 59 </Directory>
58 60
61 Alias /patches ${patchesDir}
62 <Directory ${patchesDir}>
63 DirectoryIndex index.htm index.html
64 Options Indexes FollowSymLinks MultiViews Includes
65 AllowOverride All
66 Require all granted
67 </Directory>
68
59 Alias /docs ${docsDir} 69 Alias /docs ${docsDir}
60 <Directory ${docsDir}> 70 <Directory ${docsDir}>
61 DirectoryIndex index.htm index.html 71 DirectoryIndex index.htm index.html