aboutsummaryrefslogtreecommitdiff
path: root/systems/eldiron/websites/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/eldiron/websites/default.nix')
-rw-r--r--systems/eldiron/websites/default.nix69
1 files changed, 69 insertions, 0 deletions
diff --git a/systems/eldiron/websites/default.nix b/systems/eldiron/websites/default.nix
index 68205de..feecc31 100644
--- a/systems/eldiron/websites/default.nix
+++ b/systems/eldiron/websites/default.nix
@@ -78,6 +78,75 @@ let
78 </Directory> 78 </Directory>
79 ''; 79 '';
80 }; 80 };
81 mail-autoconfig = {
82 extraConfig = let
83 autoconfig = pkgs.writeTextDir "config-v1.1.xml" ''
84 <?xml version="1.0"?>
85 <clientConfig version="1.1">
86 <emailProvider id="mail.immae.eu">
87 <domain>mail.immae.eu</domain>
88 <domain>%EMAILDOMAIN%</domain>
89 <displayName>Immae E-mail</displayName>
90 <displayShortName>Immae E-mail</displayShortName>
91
92 <incomingServer type="imap">
93 <hostname>imap.immae.eu</hostname>
94 <port>143</port>
95 <socketType>STARTTLS</socketType>
96 <username>%EMAILADDRESS%</username>
97 <authentication>password-cleartext</authentication>
98 </incomingServer>
99
100 <incomingServer type="imap">
101 <hostname>imap.immae.eu</hostname>
102 <port>993</port>
103 <socketType>SSL</socketType>
104 <username>%EMAILADDRESS%</username>
105 <authentication>password-cleartext</authentication>
106 </incomingServer>
107
108 <incomingServer type="pop3">
109 <hostname>pop.immae.eu</hostname>
110 <port>110</port>
111 <socketType>STARTTLS</socketType>
112 <username>%EMAILADDRESS%</username>
113 <authentication>password-cleartext</authentication>
114 </incomingServer>
115
116 <incomingServer type="pop3">
117 <hostname>pop.immae.eu</hostname>
118 <port>995</port>
119 <socketType>SSL</socketType>
120 <username>%EMAILADDRESS%</username>
121 <authentication>password-cleartext</authentication>
122 </incomingServer>
123
124 <outgoingServer type="smtp">
125 <hostname>smtp.immae.eu</hostname>
126 <port>587</port>
127 <socketType>STARTTLS</socketType>
128 <username>%EMAILADDRESS%</username>
129 <authentication>password-cleartext</authentication>
130 </outgoingServer>
131
132 <outgoingServer type="smtp">
133 <hostname>smtp.immae.eu</hostname>
134 <port>465</port>
135 <socketType>SSL</socketType>
136 <username>%EMAILADDRESS%</username>
137 <authentication>password-cleartext</authentication>
138 </outgoingServer>
139 </emailProvider>
140 </clientConfig>
141 '';
142 in ''
143 Alias /.well-known/autoconfig/mail "${autoconfig}"
144 <Directory ${autoconfig}>
145 AllowOverride None
146 Require all granted
147 </Directory>
148 '';
149 };
81 apaxy = { 150 apaxy = {
82 extraConfig = (mypackages-lib.apache-theme { inherit theme_root; }).apacheConfig; 151 extraConfig = (mypackages-lib.apache-theme { inherit theme_root; }).apacheConfig;
83 }; 152 };