aboutsummaryrefslogtreecommitdiff
path: root/pkgs/webapps
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/webapps')
-rw-r--r--pkgs/webapps/apache-theme/default.nix8
-rw-r--r--pkgs/webapps/default.nix4
2 files changed, 7 insertions, 5 deletions
diff --git a/pkgs/webapps/apache-theme/default.nix b/pkgs/webapps/apache-theme/default.nix
index b679afe..4b5755a 100644
--- a/pkgs/webapps/apache-theme/default.nix
+++ b/pkgs/webapps/apache-theme/default.nix
@@ -1,10 +1,12 @@
1{ theme_root ? null }: 1{ theme_root ? null }:
2rec { 2rec {
3 theme = ./theme; 3 theme = ./theme;
4 apacheConfig = '' 4 apacheConfig = let
5 theme_root' = if isNull theme_root then theme else theme_root;
6 in ''
5 <Macro Apaxy %{folder} %{ignored}> 7 <Macro Apaxy %{folder} %{ignored}>
6 Alias /theme ${if isNull theme_root then theme else theme_root} 8 Alias /theme ${theme_root'}
7 <Directory ${if isNull theme_root then theme else theme_root}> 9 <Directory ${theme_root'}>
8 Options -Indexes 10 Options -Indexes
9 AllowOverride None 11 AllowOverride None
10 Require all granted 12 Require all granted
diff --git a/pkgs/webapps/default.nix b/pkgs/webapps/default.nix
index 8151b8d..8c3eb0e 100644
--- a/pkgs/webapps/default.nix
+++ b/pkgs/webapps/default.nix
@@ -1,4 +1,4 @@
1{ callPackage, mylibs, composerEnv, lib }: 1{ callPackage, mylibs, composerEnv, lib, private }:
2rec { 2rec {
3 adminer = callPackage ./adminer {}; 3 adminer = callPackage ./adminer {};
4 apache-theme = callPackage ./apache-theme {}; 4 apache-theme = callPackage ./apache-theme {};
@@ -111,4 +111,4 @@ rec {
111 in 111 in
112 lib.attrsets.genAttrs names 112 lib.attrsets.genAttrs names
113 (name: callPackage (./yourls/plugins + "/${name}") { inherit mylibs; }); 113 (name: callPackage (./yourls/plugins + "/${name}") { inherit mylibs; });
114} 114} // private.webapps