diff options
Diffstat (limited to 'pkgs/private/webapps/chloe')
-rw-r--r-- | pkgs/private/webapps/chloe/chloe.json | 14 | ||||
-rw-r--r-- | pkgs/private/webapps/chloe/default.nix | 19 |
2 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/private/webapps/chloe/chloe.json b/pkgs/private/webapps/chloe/chloe.json new file mode 100644 index 0000000..686d751 --- /dev/null +++ b/pkgs/private/webapps/chloe/chloe.json | |||
@@ -0,0 +1,14 @@ | |||
1 | { | ||
2 | "tag": "96fc4eb-master", | ||
3 | "meta": { | ||
4 | "name": "chloe", | ||
5 | "url": "gitolite@git.immae.eu:perso/Immae/Sites/Chloe", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "git": { | ||
9 | "url": "gitolite@git.immae.eu:perso/Immae/Sites/Chloe", | ||
10 | "rev": "96fc4eb0099a29b0f9a58fb4eaec4bf14ac65f0a", | ||
11 | "sha256": "0mf15j6z86j2smm2k360cmm5djhcjbs9949pznwi57kw97vkm1s3", | ||
12 | "fetchSubmodules": true | ||
13 | } | ||
14 | } | ||
diff --git a/pkgs/private/webapps/chloe/default.nix b/pkgs/private/webapps/chloe/default.nix new file mode 100644 index 0000000..f148d4b --- /dev/null +++ b/pkgs/private/webapps/chloe/default.nix | |||
@@ -0,0 +1,19 @@ | |||
1 | { environment ? "prod" | ||
2 | , varDir ? "/var/lib/chloe_${environment}" | ||
3 | , spip, stdenv, mylibs, sassc }: | ||
4 | let | ||
5 | siteDir = stdenv.mkDerivation (mylibs.fetchedGitPrivate ./chloe.json // rec { | ||
6 | buildPhase = '' | ||
7 | make | ||
8 | ''; | ||
9 | installPhase = '' | ||
10 | cp -a . $out | ||
11 | ''; | ||
12 | buildInputs = [ sassc ]; | ||
13 | }); | ||
14 | in | ||
15 | spip.override { | ||
16 | ldap = true; | ||
17 | siteName = "chloe"; | ||
18 | inherit environment siteDir; | ||
19 | } | ||