aboutsummaryrefslogtreecommitdiff
path: root/pkgs/fiche
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/fiche')
-rw-r--r--pkgs/fiche/default.nix7
-rw-r--r--pkgs/fiche/fiche.json15
2 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/fiche/default.nix b/pkgs/fiche/default.nix
new file mode 100644
index 0000000..cc67fb0
--- /dev/null
+++ b/pkgs/fiche/default.nix
@@ -0,0 +1,7 @@
1{ stdenv, mylibs }:
2stdenv.mkDerivation (mylibs.fetchedGithub ./fiche.json // rec {
3 installPhase = ''
4 mkdir -p $out/bin
5 install -m 0755 fiche $out/bin/
6 '';
7})
diff --git a/pkgs/fiche/fiche.json b/pkgs/fiche/fiche.json
new file mode 100644
index 0000000..036de7f
--- /dev/null
+++ b/pkgs/fiche/fiche.json
@@ -0,0 +1,15 @@
1{
2 "tag": "4bba916-master",
3 "meta": {
4 "name": "fiche",
5 "url": "https://github.com/solusipse/fiche",
6 "branch": "master"
7 },
8 "github": {
9 "owner": "solusipse",
10 "repo": "fiche",
11 "rev": "4bba916e0f4a54d98a3947df7e2d0714d92a8bab",
12 "sha256": "060pxn8ns2zqszv1dlf7zcaf42avn9svya6irwy5d1ry29hp2ds9",
13 "fetchSubmodules": true
14 }
15}