aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/tools/roundcubemail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/tools/tools/roundcubemail.nix')
-rw-r--r--nixops/modules/websites/tools/tools/roundcubemail.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/nixops/modules/websites/tools/tools/roundcubemail.nix b/nixops/modules/websites/tools/tools/roundcubemail.nix
index 5fc3412..9939b77 100644
--- a/nixops/modules/websites/tools/tools/roundcubemail.nix
+++ b/nixops/modules/websites/tools/tools/roundcubemail.nix
@@ -78,8 +78,8 @@ let
78 install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions 78 install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
79 ''; 79 '';
80 }; 80 };
81 keys.tools-roundcube = { 81 keys = [{
82 destDir = "/run/keys/webapps"; 82 dest = "webapps/tools-roundcube";
83 user = apache.user; 83 user = apache.user;
84 group = apache.group; 84 group = apache.group;
85 permissions = "0400"; 85 permissions = "0400";
@@ -136,7 +136,7 @@ let
136 $config['temp_dir'] = '${varDir}/cache'; 136 $config['temp_dir'] = '${varDir}/cache';
137 $config['mime_types'] = '${apacheHttpd}/conf/mime.types'; 137 $config['mime_types'] = '${apacheHttpd}/conf/mime.types';
138 ''; 138 '';
139 }; 139 }];
140 webRoot = stdenv.mkDerivation rec { 140 webRoot = stdenv.mkDerivation rec {
141 version = "1.4-rc1"; 141 version = "1.4-rc1";
142 name = "roundcubemail-${version}"; 142 name = "roundcubemail-${version}";
@@ -154,7 +154,7 @@ let
154 ''; 154 '';
155 installPhase = '' 155 installPhase = ''
156 cp -a . $out 156 cp -a . $out
157 ln -s /run/keys/webapps/tools-roundcube $out/config/config.inc.php 157 ln -s /var/secrets/webapps/tools-roundcube $out/config/config.inc.php
158 ${builtins.concatStringsSep "\n" ( 158 ${builtins.concatStringsSep "\n" (
159 lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/plugins/${name}") plugins 159 lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/plugins/${name}") plugins
160 )} 160 )}
@@ -184,9 +184,9 @@ let
184 ''; 184 '';
185 }; 185 };
186 phpFpm = rec { 186 phpFpm = rec {
187 serviceDeps = [ "postgresql.service" "tools-roundcube-key.service" ]; 187 serviceDeps = [ "postgresql.service" ];
188 basedir = builtins.concatStringsSep ":" ( 188 basedir = builtins.concatStringsSep ":" (
189 [ webRoot "/run/keys/webapps/tools-roundcube" varDir ] 189 [ webRoot "/var/secrets/webapps/tools-roundcube" varDir ]
190 ++ lib.attrsets.mapAttrsToList (name: value: value) plugins 190 ++ lib.attrsets.mapAttrsToList (name: value: value) plugins
191 ++ lib.attrsets.mapAttrsToList (name: value: value) skins); 191 ++ lib.attrsets.mapAttrsToList (name: value: value) skins);
192 phpConfig = '' 192 phpConfig = ''