aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/chloe/production.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/chloe/production.nix')
-rw-r--r--modules/private/websites/chloe/production.nix106
1 files changed, 88 insertions, 18 deletions
diff --git a/modules/private/websites/chloe/production.nix b/modules/private/websites/chloe/production.nix
index 83f6c9b..067e8e7 100644
--- a/modules/private/websites/chloe/production.nix
+++ b/modules/private/websites/chloe/production.nix
@@ -1,50 +1,120 @@
1{ lib, pkgs, config, ... }: 1{ lib, pkgs, config, ... }:
2let 2let
3 chloe = pkgs.callPackage ./builder.nix { 3 apacheUser = config.services.httpd.Prod.user;
4 inherit (pkgs.webapps) chloe; 4 apacheGroup = config.services.httpd.Prod.group;
5 config = config.myEnv.websites.chloe.production; 5 ccfg = config.myEnv.websites.chloe.production;
6 apacheUser = config.services.httpd.Prod.user; 6 app = pkgs.callPackage ./app {
7 apacheGroup = config.services.httpd.Prod.group; 7 inherit (ccfg) environment;
8 inherit (pkgs.webapps) spip;
9 varDir = "/var/lib/chloe_production";
8 }; 10 };
9
10 cfg = config.myServices.websites.chloe.production; 11 cfg = config.myServices.websites.chloe.production;
12 webappdir = config.services.websites.webappDirsPaths.chloe_production;
11in { 13in {
12 options.myServices.websites.chloe.production.enable = lib.mkEnableOption "enable Chloe's website in production"; 14 options.myServices.websites.chloe.production.enable = lib.mkEnableOption "enable Chloe's website in production";
13 15
14 config = lib.mkIf cfg.enable { 16 config = lib.mkIf cfg.enable {
15 services.duplyBackup.profiles.chloe_prod.rootDir = chloe.app.varDir; 17 services.duplyBackup.profiles.chloe_production.rootDir = app.varDir;
16 secrets.keys = chloe.keys; 18 secrets.keys = [
19 {
20 dest = "websites/chloe/production";
21 user = apacheUser;
22 group = apacheGroup;
23 permissions = "0400";
24 text = ''
25 SetEnv SPIP_CONFIG_DIR "${./config}"
26 SetEnv SPIP_VAR_DIR "${app.varDir}"
27 SetEnv SPIP_SITE "chloe-${app.environment}"
28 SetEnv SPIP_LDAP_BASE "dc=immae,dc=eu"
29 SetEnv SPIP_LDAP_HOST "ldaps://ldap.immae.eu"
30 SetEnv SPIP_LDAP_SEARCH_DN "${ccfg.ldap.dn}"
31 SetEnv SPIP_LDAP_SEARCH_PW "${ccfg.ldap.password}"
32 SetEnv SPIP_LDAP_SEARCH "${ccfg.ldap.filter}"
33 SetEnv SPIP_MYSQL_HOST "${ccfg.mysql.host}"
34 SetEnv SPIP_MYSQL_PORT "${ccfg.mysql.port}"
35 SetEnv SPIP_MYSQL_DB "${ccfg.mysql.database}"
36 SetEnv SPIP_MYSQL_USER "${ccfg.mysql.user}"
37 SetEnv SPIP_MYSQL_PASSWORD "${ccfg.mysql.password}"
38 '';
39 }
40 ];
17 services.webstats.sites = [ { name = "osteopathe-cc.fr"; } ]; 41 services.webstats.sites = [ { name = "osteopathe-cc.fr"; } ];
18 42
19 systemd.services.phpfpm-chloe_prod.after = lib.mkAfter chloe.phpFpm.serviceDeps; 43 systemd.services.phpfpm-chloe_production.after = lib.mkAfter [ "mysql.service" ];
20 systemd.services.phpfpm-chloe_prod.wants = chloe.phpFpm.serviceDeps; 44 systemd.services.phpfpm-chloe_production.wants = [ "mysql.service" ];
21 services.phpfpm.pools.chloe_prod = { 45 services.phpfpm.pools.chloe_production = {
22 user = config.services.httpd.Prod.user; 46 user = config.services.httpd.Prod.user;
23 group = config.services.httpd.Prod.group; 47 group = config.services.httpd.Prod.group;
24 settings = chloe.phpFpm.pool; 48 settings = {
49 "listen.owner" = apacheUser;
50 "listen.group" = apacheGroup;
51 "php_admin_value[upload_max_filesize]" = "20M";
52 "php_admin_value[post_max_size]" = "20M";
53 # "php_admin_flag[log_errors]" = "on";
54 "php_admin_value[open_basedir]" = "${app.spipConfig}:${./config}:${app}:${app.varDir}:/tmp";
55 "php_admin_value[session.save_path]" = "${app.varDir}/phpSessions";
56 "pm" = "dynamic";
57 "pm.max_children" = "20";
58 "pm.start_servers" = "2";
59 "pm.min_spare_servers" = "1";
60 "pm.max_spare_servers" = "3";
61 };
25 phpOptions = config.services.phpfpm.phpOptions + '' 62 phpOptions = config.services.phpfpm.phpOptions + ''
26 extension=${pkgs.php}/lib/php/extensions/mysqli.so 63 extension=${pkgs.php}/lib/php/extensions/mysqli.so
27 ''; 64 '';
28 }; 65 };
29 system.activationScripts.chloe_prod = chloe.activationScript; 66 system.activationScripts.chloe_production = {
30 myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot; 67 deps = [ "wrappers" ];
31 services.websites.env.production.modules = chloe.apache.modules; 68 text = ''
69 install -m 0755 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir} ${app.varDir}/IMG ${app.varDir}/tmp ${app.varDir}/local
70 install -m 0750 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir}/phpSessions
71 '';
72 };
73 services.websites.webappDirs.chloe_production = app.webRoot;
74 services.websites.env.production.modules = [ "proxy_fcgi" ];
32 services.websites.env.production.vhostConfs.chloe = { 75 services.websites.env.production.vhostConfs.chloe = {
33 certName = "chloe"; 76 certName = "chloe";
34 certMainHost = "osteopathe-cc.fr"; 77 certMainHost = "osteopathe-cc.fr";
35 hosts = ["osteopathe-cc.fr" "www.osteopathe-cc.fr" ]; 78 hosts = ["osteopathe-cc.fr" "www.osteopathe-cc.fr" ];
36 root = chloe.apache.root; 79 root = webappdir;
37 extraConfig = [ 80 extraConfig = [
38 '' 81 ''
82 Use Stats osteopathe-cc.fr
83
39 RewriteEngine On 84 RewriteEngine On
40 RewriteCond "%{HTTP_HOST}" "!^www\.osteopathe-cc\.fr$" [NC] 85 RewriteCond "%{HTTP_HOST}" "!^www\.osteopathe-cc\.fr$" [NC]
41 RewriteRule ^(.+)$ https://www.osteopathe-cc.fr$1 [R=302,L] 86 RewriteRule ^(.+)$ https://www.osteopathe-cc.fr$1 [R=302,L]
87
88 Include ${config.secrets.fullPaths."websites/chloe/production"}
89
90 RewriteEngine On
91 RewriteRule ^/news.rss /spip.php?page=backend&id_rubrique=1
92
93 <FilesMatch "\.php$">
94 SetHandler "proxy:unix:${config.services.phpfpm.pools.chloe_production.socket}|fcgi://localhost"
95 </FilesMatch>
96
97 <Directory ${webappdir}>
98 DirectoryIndex index.php index.htm index.html
99 Options -Indexes +FollowSymLinks +MultiViews +Includes
100 Include ${webappdir}/htaccess.txt
101
102 AllowOverride AuthConfig FileInfo Limit
103 Require all granted
104 </Directory>
105
106 <DirectoryMatch "${webappdir}/squelettes">
107 Require all denied
108 </DirectoryMatch>
109
110 <FilesMatch "(.htaccess|rewrite-rules|.gitignore)$">
111 Require all denied
112 </FilesMatch>
42 '' 113 ''
43 (chloe.apache.vhostConf config.services.phpfpm.pools.chloe_prod.socket)
44 ]; 114 ];
45 }; 115 };
46 services.websites.env.production.watchPaths = [ 116 services.websites.env.production.watchPaths = [
47 "/var/secrets/webapps/${chloe.app.environment}-chloe" 117 config.secrets.fullPaths."websites/chloe/production"
48 ]; 118 ];
49 }; 119 };
50} 120}