aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/chloe/integration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/chloe/integration.nix')
-rw-r--r--modules/private/websites/chloe/integration.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/modules/private/websites/chloe/integration.nix b/modules/private/websites/chloe/integration.nix
index 458e414..d49a85c 100644
--- a/modules/private/websites/chloe/integration.nix
+++ b/modules/private/websites/chloe/integration.nix
@@ -13,11 +13,15 @@ in {
13 13
14 config = lib.mkIf cfg.enable { 14 config = lib.mkIf cfg.enable {
15 secrets.keys = chloe.keys; 15 secrets.keys = chloe.keys;
16 services.myPhpfpm.serviceDependencies.chloe_dev = chloe.phpFpm.serviceDeps; 16 systemd.services.phpfpm-chloe_dev.after = lib.mkAfter chloe.phpFpm.serviceDeps;
17 services.myPhpfpm.poolConfigs.chloe_dev = chloe.phpFpm.pool; 17 systemd.services.phpfpm-chloe_dev.wants = chloe.phpFpm.serviceDeps;
18 services.myPhpfpm.poolPhpConfigs.chloe_dev = '' 18 services.phpfpm.pools.chloe_dev = {
19 extension=${pkgs.php}/lib/php/extensions/mysqli.so 19 listen = chloe.phpFpm.socket;
20 extraConfig = chloe.phpFpm.pool;
21 phpOptions = config.services.phpfpm.phpOptions + ''
22 extension=${pkgs.php}/lib/php/extensions/mysqli.so
20 ''; 23 '';
24 };
21 system.activationScripts.chloe_dev = chloe.activationScript; 25 system.activationScripts.chloe_dev = chloe.activationScript;
22 system.extraSystemBuilderCmds = '' 26 system.extraSystemBuilderCmds = ''
23 mkdir -p $out/webapps 27 mkdir -p $out/webapps