aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index 9bfb80a..550b060 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -117,6 +117,11 @@ in
117 default = {}; 117 default = {};
118 type = attrsOf (submodule { 118 type = attrsOf (submodule {
119 options = { 119 options = {
120 emails = mkOption {
121 default = [];
122 description = "List of e-mails that the server can be a sender of";
123 type = listOf str;
124 };
120 ldap = mkOption { 125 ldap = mkOption {
121 description = '' 126 description = ''
122 LDAP credentials for the host 127 LDAP credentials for the host
@@ -453,7 +458,16 @@ in
453 options = { 458 options = {
454 status_url = mkOption { type = str; description = "URL to push status to"; }; 459 status_url = mkOption { type = str; description = "URL to push status to"; };
455 status_token = mkOption { type = str; description = "Token for the status url"; }; 460 status_token = mkOption { type = str; description = "Token for the status url"; };
461 http_user_password = mkOption { type = str; description = "HTTP credentials to check services behind wall"; };
456 email = mkOption { type = str; description = "Admin E-mail"; }; 462 email = mkOption { type = str; description = "Admin E-mail"; };
463 ssh_public_key = mkOption { type = str; description = "SSH public key"; };
464 ssh_secret_key = mkOption { type = str; description = "SSH secret key"; };
465 imap_login = mkOption { type = str; description = "IMAP login"; };
466 imap_password = mkOption { type = str; description = "IMAP password"; };
467 nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
468 slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
469 slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
470 contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
457 }; 471 };
458 }; 472 };
459 }; 473 };