aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index 2aa8b5e..f0e39e9 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -1104,6 +1104,23 @@ in
1104 }; 1104 };
1105 }; 1105 };
1106 }; 1106 };
1107 richie = mkOption {
1108 description = "Europe Richie configurations by environment";
1109 type = submodule {
1110 options = {
1111 mysql = mkMysqlOptions "Richie";
1112 smtp_mailer = mkOption {
1113 description = "SMTP mailer configuration";
1114 type = submodule {
1115 options = {
1116 user = mkOption { type = str; description = "Username"; };
1117 password = mkOption { type = str; description = "Password"; };
1118 };
1119 };
1120 };
1121 };
1122 };
1123 };
1107 tellesflorian = mkOption { 1124 tellesflorian = mkOption {
1108 description = "Tellesflorian configurations by environment"; 1125 description = "Tellesflorian configurations by environment";
1109 type = 1126 type =